Ticket #6849 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Paragragh tags should not be added inside <li> tags

Reported by: james c Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.5.3
Component: Core : Lists Version: 3.4
Keywords: IBM Cc: damo, joek, satya

Description

Steps to Reproduce the defect:

  1. Open the Ajax sample.
  2. Click on the numbered list icon.
  3. Click on Heading 1 paragraph format.
  4. Type some text & press Enter.
  5. Type some more text & press Enter.

Expected: The source should look like this:

<ol>
	<li>
		<h1>Heading 1 List Item 1</h1>
	</li>
	<li>
		Normal List Item 2
	</li>
	<li>
		Normal List Item 3
	</li>
</ol>

Actual: But instead there are <p> tags added inside <li> tags so the output looks like this:

<ol>
	<li>
		<h1>Heading 1 List Item 1</h1>
	</li>
	<li>
		<p>Normal List Item 2</p>
	</li>
	<li>
		<p>Normal List Item 3</p>
	</li>
</ol>

Attachments

6849.patch (2.0 KB) - added by garry.yao 3 years ago.
6849_2.patch (1.6 KB) - added by garry.yao 3 years ago.

Change History

comment:1 Changed 3 years ago by krst

  • Status changed from new to confirmed
  • Version changed from 3.4.3 (SVN - trunk) to 3.4

Confirmed the redundant <p>'s are added

Changed 3 years ago by garry.yao

comment:2 Changed 3 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:3 Changed 3 years ago by damo

Can we target this for a milestone?

comment:4 Changed 3 years ago by wwalc

  • Milestone set to CKEditor 3.5.3

comment:5 Changed 3 years ago by fredck

  • Status changed from review to review_failed

After patch:

  1. Load this:
<ul>
	<li>
		<h1>Some text</h1>
	</li>
</ul>
  1. Put the caret in the middle of "Some text".
  2. Hit ENTER.

An empty <h1> is appended to the first list item.

Changed 3 years ago by garry.yao

comment:6 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review

Um...looks like the first patch was just heading the wrong way, which doesn't take into consideration the inline style continuation.

comment:7 Changed 3 years ago by Saare

  • Status changed from review to review_passed

comment:8 Changed 3 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [6563].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy