Opened 7 years ago

Closed 6 years ago

#6850 closed Task (fixed)

About CKEditor dialog window should contain the User's Guide link

Reported by: Anna Tomanek Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.6
Component: General Version:
Keywords: Cc:

Description (last modified by Anna Tomanek)

Since users are accustomed to finding "Help" under the icon marked with a question mark, the About CKEditor dialog window should contain a link to CKEditor 3.x User's Guide. Some users might not be aware that the online editor embedded in a website they are using is CKEditor and might not know its documentation site.

Suggested wording:

Check <a href="http://docs.cksource.com/CKEditor_3.x/Users_Guide/Quick_Reference">CKEditor User's Guide</a> for help.

or similar.

Attachments (1)

6850.patch (1.1 KB) - added by Sa'ar Zac Elias 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by Sa'ar Zac Elias

Component: UI : DialogsGeneral
Milestone: CKEditor 3.5.1
Status: newconfirmed
Type: New FeatureTask

comment:2 Changed 7 years ago by Garry Yao

Keywords: Discussion added
Milestone: CKEditor 3.5.1
Status: confirmedpending

Generally the end application strip out the "About" dialog, so I believe it's more of the developers' initiative to do that.

comment:3 Changed 7 years ago by Anna Tomanek

Overall, I agree that since the toolbar is customizable some/most developers remove the About CKEditor button, BUT:
(1) If we assume it is removed, why do we care to place the product website link, copyright note, and licensing info there?
(2) Of all those things that are already there the documentation link seems (to me) to be most crucial to end users, especially given the mental association between a qustion mark and "Help". I can imagine this can convince at least some developers to leave the button as it partially takes the burden of supporting their users in using CKEditor from their shoulders.

I'm not saying that this will solve all support problems, but since not much work is required on our part, why not try?

comment:4 Changed 7 years ago by Anna Tomanek

Description: modified (diff)

As suggested by Wiktor, the proposed link was modified to point directly to the Quick Reference section of the User's Guide.

comment:5 Changed 7 years ago by Wiktor Walc

Status: pendingconfirmed

+1 for a link to User's Guide:

  • (New) users do expect to find some help by clicking on the question mark button
  • This way we'll promote the documentation website, encouraging newcomers to read it first, before trying to work with CKEditor
  • Even if the About button is removed later by many developers, adding a link will make no harm to the "About" dialog window if we add it carefully (currently the About dialog looks quite nice).

comment:6 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 6850.patch added

comment:7 Changed 6 years ago by Frederico Caldeira Knabben

Keywords: Discussion removed
Milestone: CKEditor 3.6
Status: reviewreview_passed

"3.x" is really a techie thing... let's have the following phrase instead: "Check the User's Guide for help.", or anything that Anna will find more appropriate.

comment:8 Changed 6 years ago by Anna Tomanek

Description: modified (diff)

Let's leave it at:
"Check CKEditor User's Guide for help."
to avoid any ambiguity.

Code in ticket description updated.

comment:9 Changed 6 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6728].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy