Ticket #6863 (closed Bug: fixed)

Opened 3 years ago

Last modified 18 months ago

Full page mode: Spell check dialog causes a JS error

Reported by: wwalc Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.3
Keywords: HasPatch, Review? Cc: SpellChecker.net

Description

When SCAYT is enabled and the spell check dialog is used to check the document, a JavaScript error occurs (empty style tags are covered by #6859).

  1. Open _samples/fullpage.html
  2. Start with:
    <html>
    	<head>
    	</head>
    	<body>
    		<p>
    			Write your email message here schol.</p>
    		<p>
    			You can also...</p>
    	</body>
    </html>
    
  3. Enable SCAYT
  4. Open the Check Spell dialog
  5. Click on Finish Checking
  6. Open the Check Spell dialog again
  7. Click on Finish Checking
  8. Result: a javascript error occurred:

Tried to register widget with id==scayt_2 but that id is already registered http://svc.spellchecker.net/scayt26/_base.xd.js Line 880

Confirmed in Safari 5.0.3 and Firefox 3.6.13.

(js error moved from #6859)

Attachments

6863.patch (1.1 KB) - added by SpellChecker.net 3 years ago.

Change History

comment:1 Changed 3 years ago by wwalc

  • Status changed from new to confirmed
  • Version changed from 3.5 (SVN - 3.5.x) to 3.3
  • Milestone CKEditor 3.5 deleted

Not a regression, I've managed to confirm it in 3.3.

Changed 3 years ago by SpellChecker.net

comment:2 Changed 3 years ago by SpellChecker.net

  • Keywords HasPatch, Review? added

WSC should behave the same way the "Source" button works: save SCAYT state and disable it before launching WSC and restore SCAYT state after WSC is closed.

comment:3 Changed 18 months ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to fixed

I was not able to reproduce it in latest CKEditor 3.6.5.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy