Opened 8 years ago

Closed 8 years ago

#6859 closed Bug (fixed)

Full page mode: Spell check dialog adds extra empty style tags

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone: CKEditor 3.5
Component: UI : Spell Checker Version: 3.5
Keywords: Cc: WebSpellChecker.net

Description (last modified by Wiktor Walc)

When SCAYT is enabled and the spell check dialog is used to check the document, empty extra style tags are added to the document and a JavaScript error occurs (reported in #6863).

  1. Open _samples/fullpage.html
  2. Start with:
    <html>
    	<head>
    	</head>
    	<body>
    		<p>
    			Write your email message here schol.</p>
    		<p>
    			You can also...</p>
    	</body>
    </html>
    
  3. Enable SCAYT
  4. Open the Check Spell dialog
  5. Click on Finish Checking
  6. Open the Check Spell dialog again
  7. Click on Finish Checking
  8. Result: empty style tags are now present in the document:
    <html>
    	<head>
    		<title></title>
    		<style cke_temp="2" type="text/css">
    		</style>
    		<style cke_temp="2" type="text/css">
    		</style>
    		<style cke_temp="2" type="text/css">
    		</style>
    		<style cke_temp="2" type="text/css">
    		</style>
    	</head>
    	<body class="scayt-enabled">
    		<p>
    			Write your email message here schol.</p>
    		<p>
    			You can also...</p>
    	</body>
    </html>
    

JavaScript error:

Tried to register widget with id==scayt_2 but that id is already registered http://svc.spellchecker.net/scayt26/_base.xd.js Line 880

Confirmed in Safari 5.0.3 and Firefox 3.6.13. Looks like a regression introduced in 3.5

Change History (6)

comment:1 Changed 8 years ago by Garry Yao

Status: newconfirmed

We've unified the custom attributes starting with "data-cke-temp", please make update at your side.

comment:2 Changed 8 years ago by Krzysztof Studnik

Confirmed for CKE3.5, Does not occur in 3.4.3

comment:3 Changed 8 years ago by WebSpellChecker.net

Issue with styles is our server issue, while JS error occurs because of WSC and SCAYT conflict (when they work together).

Also we propose to divide this ticket into two separate tickets: one about styles and another about JS error.

comment:4 Changed 8 years ago by Wiktor Walc

Description: modified (diff)

JS error moved to #6863

comment:5 Changed 8 years ago by WebSpellChecker.net

Keywords: Review? added

We have updated SCAYT core with new attributes ("data-cke-temp" instead of "cke_temp") and restarted our hosting. Now SCAYT version should show 2.6.1 (224) and it contains the appropriate fix.

comment:6 Changed 8 years ago by Wiktor Walc

Keywords: Review? removed
Resolution: fixed
Status: confirmedclosed

I cannot reproduce the issue anymore.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy