Ticket #6866 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Image link target field not correctly set when editing an existing image.

Reported by: JoeK Owned by: Saare
Priority: Normal Milestone: CKEditor 3.4.3
Component: General Version: 3.4.3
Keywords: IBM Cc: satya, damo, jamcunni@…

Description (last modified by garry.yao) (diff)

  1. Open the image dialog.
  1. Fill in the image information.
  1. On the Link tab enter a URL and set the Target field to 'New Window'.
  1. Click OK to insert the image.
  1. Right click on the inserted image and choose Image Properties from the context menu.
  1. Click on the Link tab on the Image dialog.

Observe that the Target field is incorrectly set to '<not set>'. The anchor tag's target attribute does contain the correct value, '_blank'.

Attachments

6866.patch (556 bytes) - added by Saare 3 years ago.

Change History

comment:1 Changed 3 years ago by Saare

  • Status changed from new to confirmed
  • Milestone set to CKEditor 3.4.3

comment:2 Changed 3 years ago by Saare

Regression of [6136].

Changed 3 years ago by Saare

comment:3 Changed 3 years ago by Saare

  • Status changed from confirmed to review
  • Owner set to Saare

Reverted [6136] as I'm not able to reproduce #6673 anymore.

comment:4 Changed 3 years ago by garry.yao

  • Status changed from review to review_failed
  • Description modified (diff)

#6673 is still reproducible but just to add back the "if ( type == LINK )", as the dialog fields are setup twice.

comment:5 Changed 3 years ago by Saare

  • Status changed from review_failed to review

Neither me or Tobiasz can reproduce #6673 after the patch.

comment:6 Changed 3 years ago by tobiasz.cudnik

I can't reproduce #6673 anymore, but the TC of this ticket fails because of the second invocation of the setup, when it's value is correct, but the new value is null.

comment:7 Changed 3 years ago by tobiasz.cudnik

  • Status changed from review to review_failed

comment:8 Changed 3 years ago by tobiasz.cudnik

  • Owner changed from Saare to tobiasz.cudnik
  • Status changed from review_failed to review

I had some code changes when testing this TC, it works fine with 6866.patch.

comment:9 Changed 3 years ago by tobiasz.cudnik

  • Status changed from review to review_passed

comment:10 Changed 3 years ago by james c

  • Cc satya, damo, jamcunni@… added; satya damo removed

comment:11 Changed 3 years ago by Saare

  • Owner changed from tobiasz.cudnik to Saare
  • Status changed from review_passed to assigned

comment:12 Changed 3 years ago by Saare

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [6223].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy