Opened 8 years ago

Closed 6 years ago

#6874 closed Bug (fixed)

[Opera] Selection mangled after apply inline style (CORE-41462)

Reported by: Garry Yao Owned by:
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.6.6
Component: Core : Selection Version: 3.6.6
Keywords: Opera Cc: Hallvord R. M. Steen (Opera Software)

Description

  1. Load any of the default sample page, make the following selection:
    <p>
    	This is so[me <strong>sam]ple text</strong>.</p>
    
  2. Apply any of the inline style
  • Actual Result: Note the selection is changed.

Change History (11)

comment:1 Changed 8 years ago by Garry Yao

Status: newconfirmed

The bug applies to also any selection that partially cover an inline element, not a regression though.

comment:2 Changed 8 years ago by Hallvord R. M. Steen (Opera Software)

Cc: Hallvord R. M. Steen (Opera Software) added

Seems to WFM in O11/CK3.5

comment:4 Changed 8 years ago by Garry Yao

Still in trunk with O11.

comment:5 Changed 8 years ago by Hallvord R. M. Steen (Opera Software)

Wondering if this might be related to Opera's bug CORE-3906..

I note that it's a matter of broken selection rendering - try clicking e.g. "Bold" several times. The entire highlighted selection is not bolded and unbolded, only the characters that were actually selected earlier!

comment:6 Changed 8 years ago by Hallvord R. M. Steen (Opera Software)

Summary: [Opera] Selection mangled after apply inline style[Opera] Selection mangled after apply inline style (CORE-41462)

Finally managed to return to this - confirmed it is an Opera bug, and it's now reported as CORE-41462 on our side.

comment:7 Changed 7 years ago by Frederico Caldeira Knabben

Even though CORE-41462 is marked as fixed, it is still reproducible.
(Opera/9.80 (Macintosh; Intel Mac OS X 10.8.2; U; en) Presto/2.10.289 Version/12.02)

comment:8 Changed 7 years ago by Piotrek Koszuliński

Unfortunately yesterday I reported the same issue on v4 (#9447) and with the latest Opera 12.02. Except that it happens more often and in both "directions". I'd even say that it completely messes up the usability of the editor.

comment:9 Changed 7 years ago by Garry Yao

Milestone: CKEditor 3.6.6
Resolution: fixed
Status: confirmedclosed

Ported #9447 from v4 with [7655] as a workaround for this issue.

comment:10 Changed 6 years ago by Wiktor Walc

Resolution: fixed
Status: closedreopened

The selection is in fact broken in Opera 12.12 because of this commit ([7655]).

  1. Apply e.g. italic style to
<p>
	This is so[me <strong>sam]ple text</strong>.</p>
<p>
	This is some <strong>sam[ple text</strong>. You ar]e using <a href="http://ckeditor.com/">CKEditor</a>.</p>
  • rev 7654: selection is okay
  • rev 7655: selection over "You ar" is lost

I am no longer able to reproduce the issue from TC if I revert [7655] in trunk.

comment:11 Changed 6 years ago by Jakub Ś

Status: reopenedconfirmed
Version: 3.03.6.6 (SVN - trunk)

I have checked this on various systems and had the same results as @wwalc - it works as expected on Opera 12.12 from version 3.0 but without this revision.

I'm changing version to trunk rev. [7655] from 3.0

comment:12 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: confirmedclosed

Reverted [7655] with [7683]. It is not necessary any more.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy