Opened 6 years ago

Closed 6 years ago

#9447 closed Bug (fixed)

[Opera] Selection is expanded up to the next element after applying one of basic styles

Reported by: Piotrek Koszuliński Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 4.0
Component: Core : Selection Version: 4.0
Keywords: Opera Cc:

Description

  1. Save and open attached sample.
  2. Select "[test te]st test test."
  3. Press bold 3 times.
  • Expected: bold applied, bold removed, bold applied - 3x for the same selection.
  • Actual: For the third time selection expands to the start of <u> element.

Attachments (2)

test.html (457 bytes) - added by Piotrek Koszuliński 6 years ago.
sel.ogv (165.3 KB) - added by Piotrek Koszuliński 6 years ago.

Download all attachments as: .zip

Change History (18)

Changed 6 years ago by Piotrek Koszuliński

Attachment: test.html added

comment:1 Changed 6 years ago by Piotrek Koszuliński

comment:2 Changed 6 years ago by Piotrek Koszuliński

This issue was introduced by https://github.com/ckeditor/ckeditor-dev/commit/feb2952, but it was fixed by https://github.com/ckeditor/ckeditor-dev/commit/e618e8c few days before. And that's the one which parts were reverted in feb2952.

What's more - 2 minutes before e618e8c on https://github.com/ckeditor/ckeditor-dev/commit/6a707b6 issue was introduced for the first time.

History:

Changed 6 years ago by Piotrek Koszuliński

Attachment: sel.ogv added

comment:3 Changed 6 years ago by Piotrek Koszuliński

It looks like we have similar (but occurring less often) issue on v3 (from 3.0). I was able to find a ticket #6874 which says that it's Opera's issue.

However, there's a difference in behaviour between v3 and v4. Much probably there are two overlapping issues.

comment:4 Changed 6 years ago by Jakub Ś

Status: newconfirmed

comment:5 Changed 6 years ago by Piotrek Koszuliński

After additional tests I'm pretty sure that there's no other issue, but the original #6874 just happens more often after commits listed in comment:2. So target of this issue should be to revert to previous state of occurrence frequency.

Last edited 6 years ago by Piotrek Koszuliński (previous) (diff)

comment:6 Changed 6 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedassigned

comment:7 Changed 6 years ago by Garry Yao

Status: assignedreview

comment:8 Changed 6 years ago by Garry Yao

Opened t/9447 to revert part of 6a707b6 on Opera.

comment:9 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_passed

I pushed style fixes to be squashed into main commit.

comment:10 Changed 6 years ago by Garry Yao

Keywords: Opera added
Resolution: fixed
Status: review_passedclosed

comment:11 Changed 6 years ago by Piotrek Koszuliński

I masterised also style fixes you forgot to squash.

comment:12 Changed 6 years ago by Garry Yao

Resolution: fixed
Status: closedreopened

The original fix in comment:10 is reverted because of #9468.

comment:13 Changed 6 years ago by Garry Yao

Resolution: fixed
Status: reopenedclosed

I found another simple fix to this issue, which fix also #6874, it's safe change to be landed on master.

https://github.com/ckeditor/ckeditor-dev/commit/9b921f74229f0d946417c7d5bc5f501d5135c2d4

comment:14 Changed 6 years ago by Piotrek Koszuliński

Please fix coding style in 9b921f74. Update for #6874 will be needed too (however we still need it for v3).

comment:15 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: closedreopened

comment:16 Changed 6 years ago by Garry Yao

Resolution: fixed
Status: reopenedclosed

Coding style fixed...I would port this change to v3 on #6874.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy