Opened 7 years ago

Closed 7 years ago

#9468 closed Bug (fixed)

[Opera] Apply block style moves cursor to the start of block

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 4.0
Component: Core : Styles Version: 4.0
Keywords: Opera Cc:

Description (last modified by Garry Yao)

  1. Load replacebyclass sample page with the following content and selection:
    <p>foobar^</p>
    
  2. Open Format combo to apply any block style;
  • Actual: Format get applied with cursor collapsed to the start of block.

Test fails: http://ckeditor4.t/dt/core/style/editor.html?name=test-applyremove-style-on-editor---basic

Change History (4)

comment:1 Changed 7 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

Regression of c83f76.

comment:2 Changed 7 years ago by Piotrek Koszuliński

I can't reproduce this issue. And that test was failing for a couple of months.

comment:3 Changed 7 years ago by Garry Yao

Description: modified (diff)

Ok, the reproducing of ticket tc is not constant, but it can be constantly produced if the original cursor position is at the end of block.

Test test failure I'm pointing to, is particularly the following TC, that are masked by another unrelated failure in the same test:

this.assertApplyStyle( '<p>foo^</p>', '<h1 class="foo" style="text-align:right;">foo^</h1>', block );

comment:4 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

The regressed change is reverted.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy