Opened 6 years ago

Closed 6 years ago

#9448 closed Bug (fixed)

[Opera&Inline] Selection is lost on click in toolbar

Reported by: Piotrek Koszuliński Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 4.0
Component: Core : Selection Version: 4.0
Keywords: Opera Cc: Hallvord R. M. Steen (Opera Software)

Description (last modified by Piotrek Koszuliński)

  1. Open inlineall sample.
  2. Focus one of editors and select some text.
  3. Try to apply basic styles, lists (when at least two paragraphs selected) or to open any combo.
  • Expected: Style is applied or selection is kept when combo opened.
  • Actual: Styles very rarely get applied and (in fact "because") selection is lost.

Change History (7)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:2 Changed 6 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

This doesn't affect v3 and framed wysiwyg.

comment:3 Changed 6 years ago by Garry Yao

Status: assignedreview

This's caused by an Opera bug which can be verified with the following tc:

http://jsfiddle.net/DpbTT/8/

In short "unselectable" attribute is not able to work on a span, to keep the editable text selection, when clicking inside of a button.

Considering it's bad to change the toolbar structure just to workaround this bug, I'm proposing a selection lock to resolve the issue here.

comment:4 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_passed

Fix works, is rough, but we've got no choice.

comment:5 Changed 6 years ago by Piotrek Koszuliński

Cc: Hallvord R. M. Steen (Opera Software) added

comment:6 Changed 6 years ago by Garry Yao

A Opera browser fix would be still very desired for this issue, as other editor UIs will be potentially suffered from this bug as well.

comment:7 Changed 6 years ago by Garry Yao

Keywords: Opera added
Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy