Ticket #6892 (closed Bug: invalid)

Opened 3 years ago

Last modified 3 years ago

BIDI: Incorrect behaviour when copying and pasting RTL list from within a table

Reported by: james c Owned by:
Priority: Normal Milestone:
Component: Core : BiDi Version: 3.4.3
Keywords: IBM Discussion Cc: damo, joek, satya, garry.yao

Description

Steps to Reproduce:

  1. Open the Ajax sample.
  2. Insert a table.
  3. Click into the first cell & click RTL icon in the toolbar.
  4. Keep the cursor in the first cell & type 3 paragraphs of text.
  5. Select all 3 paragraphs & click on the Bulleted List icon.
  6. See the Bulleted List is in the RTL language direction.
  7. Copy the Bulleted List and paste it in the editor outside of the table.

Expected: The Bulleted List that was pasted outside of the table has RTL language direction.

Actual: The Bulleted List that was pasted outside of the table has LTR language direction.

Attachments

Copy and paste list from table defect.jpg (44.1 KB) - added by james c 3 years ago.

Change History

Changed 3 years ago by james c

comment:1 Changed 3 years ago by krst

  • Keywords Discussion added
  • Status changed from new to confirmed
  • Component changed from Core : Pasting to Core : BiDi
  • Cc garry.yao added

Confirmed, RTL is set to Table cell, not to its content:

<tbody>
   <tr>
	<td dir="rtl">
		<ul>
 		   <li>
			1</li>
...

That is why content of a cell, copied and pasted outside of table is set to LTR. I think it was developer's intention, not a bug.

comment:2 Changed 3 years ago by garry.yao

  • Status changed from confirmed to closed
  • Resolution set to invalid

Note that clipboard operation doesn't takes are of applied text direction in browser, try taking a line of text from some RTL web page and paste it into editor.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy