Opened 9 years ago

Closed 9 years ago

#6894 closed Bug (invalid)

Language direction on table is <not set> when LTR icon is clicked

Reported by: James Owned by:
Priority: Normal Milestone:
Component: Core : BiDi Version: 3.4
Keywords: IBM Cc: Damian, joek, Satya Minnekanti

Description

Steps to reproduce:

  1. Open the Ajax sample.
  2. Click on the Insert table icon.
  3. Click on the Advanced tab and select "Left to Right (LTR)" from the language direction combo box & click OK.
  4. See that a table is created with language direction set to LTR.
  5. Press CTRL + A to select the entire table & click on the RTL icon.
  6. See that the table now has language direction set to RTL.
  7. Press CTRL + A to select the entire table & click on the LTR icon.
  8. Right click on the table & select Table Properties from the context menu.
  9. Click on the Advanced tab and check the value in the language direction combo box.

Expected: The value in the combo box is Left to Right (LTR).

Actual: The value in the combo box is <not set>.

Change History (2)

comment:1 Changed 9 years ago by Krzysztof Studnik

Status: newconfirmed
Version: 3.4.33.4

Confirmed since 3.4

comment:2 Changed 9 years ago by Garry Yao

Resolution: invalid
Status: confirmedclosed

The dialog field reflects explicit text direction instead of computed style.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy