Opened 12 years ago

Closed 6 years ago

#691 closed Bug (duplicate)

Default foreground colour not set

Reported by: tenwit@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc:

Description

Throughout the editor (main editing pane, all the toolbar text and style/font/etc. dropdowns) the background colour is set but the foreground colour is left at the default. For those wierdos like me that have a dark default background and white foreground, FCKeditor is essentially illegible, because the default white text can't be read against the explicitly-defined white background.

Either the default foreground needs to be explicitly set to black, or the default background shouldn't be set to white.

I added "color: #000000" to the body clause in fck_editorarea.css which fixed the text area and the style dropdown, but I couldn't figure out where the format/font/size dropdowns are configured.

Aside: this also applies to www.fckeditor.net; fortunately the Firefox Text-bgcolor fixer automatically changes the foreground text colour to black, so I can read that. But it would be cool if that got fixed too.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1391476&group_id=75348&atid=543653

Change History (3)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to tenwit@…

comment:2 Changed 12 years ago by Martin Kou

Keywords: Confirmed added

comment:3 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

I'm marking this ticket as duplicate of #1601.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy