Opened 9 years ago

Closed 6 years ago

#6955 closed Bug (invalid)

Attributes duplicated from current tag to new tag when inserting a new line

Reported by: rapdup Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: 3.0
Keywords: Cc:

Description (last modified by Krzysztof Studnik)

In any browser:

  1. Goto Source view
  2. Create a div or p tag
  3. Include some styling such as a border with this tag
  4. Include some content with the tag
    <div style="border-top: 3px solid red">Hello</div>
    
  5. Switch to WYSIWYG mode
  6. Place the cursor at the end of the content just created
  7. Add a new line

Expected: A new line should appear without content and without styling

Actual: A new line without content is created, but the styling is copied from the previous line

Attachments (2)

Screen shot 2011-01-10 at 1.37.22 PM.png (87.1 KB) - added by rapdup 9 years ago.
Screenshot
Screen shot 2011-01-10 at 1.39.06 PM.png (97.4 KB) - added by rapdup 9 years ago.
Screenshot of source

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by rapdup

Screenshot

Changed 9 years ago by rapdup

Screenshot of source

comment:1 Changed 9 years ago by Krzysztof Studnik

Component: GeneralCore : Styles
Description: modified (diff)
Status: newconfirmed
Version: 3.4.23.0

comment:2 Changed 6 years ago by radariii

Is there *any* chance of this bug being fixed in an upcoming release?

comment:3 Changed 6 years ago by Jakub Ś

This is old bug report and no one has looked at it for a long time but reading it today gave me impression this behaviour is correct.

This is just my point of view but it looks quite correct to create div with some inline styling or classes and continue this styling on enter.
If one wishes to remove such styling he just needs to select this newly created div and press Remove Formatting.

  • if there is text within this div - you can select text with mouse and press Remove Formatting Button
  • if there is no text you can select this div with SHIFT+LEFT ARROW or press div element on elements path and then press Remove Formatting Button.

comment:4 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: confirmedclosed

I have consulted this issue with my colleagues and final conclusion is that this is by design.

I'm closing this issue as invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy