Opened 8 years ago

Closed 8 years ago

#7008 closed Bug (fixed)

Clipboard toolbar status wrong

Reported by: Garry Yao Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.5.1
Component: UI : Toolbar Version: 3.5.1
Keywords: Cc:

Description

  1. Load any sample page in IE;
  2. Click on "Select All" button;
  3. Note "Cut" button are still in disabled state.

Attachments (1)

7008.patch (1.9 KB) - added by Sa'ar Zac Elias 8 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by Garry Yao

Status: newconfirmed

Regression of [6311], toolbar buttons states are not "selectionchange" aware.

comment:2 Changed 8 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedassigned

comment:3 Changed 8 years ago by Wiktor Walc

Milestone: CKEditor 3.5.1

Changed 8 years ago by Sa'ar Zac Elias

Attachment: 7008.patch added

comment:4 Changed 8 years ago by Sa'ar Zac Elias

Status: assignedreview

comment:5 Changed 8 years ago by Garry Yao

Status: reviewreview_failed

Patch doesn't make a change for me.

comment:6 in reply to:  5 Changed 8 years ago by Garry Yao

Replying to garry.yao:

Patch doesn't make a change for me.

My fault, the patch works for the ticket TC while let's check also the following:

  1. Put cursor collapsed in content;
  2. Check the "Copy" button is enabled;
  3. Now move the selection one character back/forward with arrow key;
  • Actual Result: button is disabled now.

comment:7 Changed 8 years ago by Garry Yao

It looks like that more related to #7009, so this ticket is already a R+.

comment:8 Changed 8 years ago by Wiktor Walc

Status: review_failedreview_passed

comment:9 Changed 8 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6371].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy