Opened 9 years ago

Closed 9 years ago

#7041 closed Bug (fixed)

Firefox: Unable to escape from the link

Reported by: Wiktor Walc Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.5.1
Component: Core : Styles Version: 3.5.1
Keywords: Firefox Cc:

Description

Regression caused by [6272]. Confirmed in Firefox @ Win 7 and Firefox @ Mac.

  • Load the replacebyclass sample
  • put the cursor at the end of the line and insert a link using the Link dialog
  • click with a mouse at the end of the link or use the right arrow key to go at the end of the link
  • press space, start typing
  • result: instead of typing plain text, we're still inside of a link.

Attachments (2)

7041.patch (739 bytes) - added by Garry Yao 9 years ago.
7041_2.patch (2.7 KB) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 9 years ago by Wiktor Walc

Status: newconfirmed

comment:2 Changed 9 years ago by Krzysztof Studnik

confirmed for Firefox3.6.13 Win7/xp/2k3

comment:3 Changed 9 years ago by Wiktor Walc

Simplified TC:

Follow the same set of steps in http://rev.ckeditor.com/ckeditor/trunk/6272/_samples/replacebyclass.html to see that it stopped working there.

Changed 9 years ago by Garry Yao

Attachment: 7041.patch added

comment:4 Changed 9 years ago by Garry Yao

Component: GeneralCore : Styles
Owner: set to Garry Yao
Status: confirmedreview

comment:5 Changed 9 years ago by Wiktor Walc

The attached patch solves the problem for me when I use the "End" key and a mouse to go at the end of a link. There is still one problem however - the right arrow key used to work in R6271. With this patch I'm still inside of a link when I use the right arrow key straight after inserting a link to move to the end of it.

Also with this patch #7043 seems to be fixed.

comment:6 Changed 9 years ago by Garry Yao

I'm not able to reproduce the arrow key issue, considering that the regression ([6272]) is addressed, and right now at least TC works with both mouse click and "End" key, we could continue the investigation with another new ticket.

comment:7 Changed 9 years ago by Wiktor Walc

The right arrow key issue moved into #7053.

comment:8 Changed 9 years ago by Sa'ar Zac Elias

Status: reviewreview_failed

Ticket TC fails while TC in comment:3 is working using the patch.

Changed 9 years ago by Garry Yao

Attachment: 7041_2.patch added

comment:9 Changed 9 years ago by Garry Yao

Status: review_failedreview

Ideally the patch could fix #5978, while as I'm featuring only the ticket TC here so I didn't test it in Safari.

comment:10 Changed 9 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:11 Changed 9 years ago by Sa'ar Zac Elias

Patch also fixes #7043.

comment:12 Changed 9 years ago by Wiktor Walc

Resolution: fixed
Status: review_passedclosed

Fixed by Garry with [6373].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy