Opened 8 years ago

Closed 8 years ago

#7049 closed Bug (duplicate)

Find highlight not available on readonly elements.

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5
Keywords: Cc:

Description

  1. Load the editor with the following content:
    <p contenteditable="false">inside read-only paragraph</p>
    
  2. Open find dialog and search for "read-only"
    • Actual Result: When clicking on "Find" button the word matched is not highlighted.

Change History (2)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed
Version: 3.33.5

This summary should rather sound:
JS error thrown when searching for text in read-only elements.

I did not encounter any highlight problems but form CKEditor 3.5 when you try to search for text that is inside read-only element the JS error is thrown.

Message: currentNode is null
Line: 455
URI: /ckeditor/_source/plugins/styles/plugin.js

comment:2 Changed 8 years ago by Wiktor Walc

Resolution: duplicate
Status: confirmedclosed

Oops, as a result it's impossible to close the dialog.

In any case, it's a duplicate of #6957.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy