Opened 7 years ago

Closed 4 years ago

#7108 closed Bug (fixed)

[Opera] Broken content after pasting as plain text and then edited

Reported by: Piotr Łukaszewski Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.5
Keywords: Opera Cc: satya_minnekanti@…, Hallvord R. M. Steen (Opera Software)

Description

In Opera when pasting as plain text the content is a bit messed up when you go and edit it in a specific way.

Steps to reproduce:
1. Open the demo of CKEditor ( http://ckeditor.com/demo ) and clear the content area with "New Page" button
2. Open attached example.txt and copy all the contents (four "paragraphs") to the clipboard
3. Paste the copied text into CKEditor with "Paste as plain text" button
4. Select and then delete the first paragraph (you end up with an empty first paragraph and the remaining three paragraphs)
5. Hit the delete key again to remove the empty paragraph
6. This results in the second and third paragraph merging together creating one paragraph while they should stay separate

If, after initial pasting the text, you switch to the source view and back everything works fine and the issue is not reproducible.

And if you look at the element's path of each paragraph right after initial paste you'll see that every other paragraph has a path of "body p p" while each should have only "body p".

This issue is only with Opera (I checked with latest stable version 11.01) and not present in Chrome, Firefox nor IE. OS is Windows XP.

Attachments (1)

example.txt (1.1 KB) - added by Piotr Łukaszewski 7 years ago.
Some testing content

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by Piotr Łukaszewski

Attachment: example.txt added

Some testing content

comment:1 Changed 7 years ago by Piotr Łukaszewski

I forgot to mention that this issue was introduced in the 3.5.0 version.

comment:2 Changed 7 years ago by Krzysztof Studnik

Keywords: Opera added
Status: newconfirmed
Version: 3.5.2 (SVN - trunk)3.5

Confirmed. Thanks.

comment:3 Changed 7 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:4 Changed 7 years ago by Hallvord R. M. Steen (Opera Software)

Cc: Hallvord R. M. Steen (Opera Software) added

comment:5 Changed 6 years ago by Piotr Łukaszewski

Today I updated to 3.6.1 and the initial issue is gone... but now it puts an empty first line (which is converted to an empty paragraph) when you paste plain text that has line breaks... It is reproducible with the demo...

I have:
CKEditor 3.6.1 (revision 7072)
Opera 11.11 (build 2109) - latest stable

comment:6 Changed 6 years ago by Hallvord R. M. Steen (Opera Software)

If the original issue is now gone, I'd rather close this bug and open a new one for the different issue ;-).

comment:7 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy