Opened 8 years ago

Closed 7 years ago

#7117 closed Bug (worksforme)

Copy paste in a table

Reported by: Flavien CROCHARD Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: 3.4
Keywords: Chrome Cc:

Description (last modified by Krzysztof Studnik)

  • Insert a table.
  • Copy and paste something in the first cell.

The content is put outside the td if you go in the source. When you come back to the wysiwyg, the text is at the top of the document.

Attachments (1)

krst_20110202-01.png (23.5 KB) - added by Krzysztof Studnik 8 years ago.
Selection copied and pasted back into same cell

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Krzysztof Studnik

Attachment: krst_20110202-01.png added

Selection copied and pasted back into same cell

comment:1 Changed 8 years ago by Krzysztof Studnik

Description: modified (diff)
Keywords: Chrome added
Status: newconfirmed
Version: 3.5.2 (SVN - trunk)3.4

Confirmed for Chrome8.

  • I entered some text into first cell,
  • then selected text and cell as on attached screen
  • I copied it and pasted back int the same place

Result:

<table border="1" cellpadding="1" cellspacing="1" style="width: 500px; ">
	<tbody>
		<tr>
			<td>
				sdf</td>
		</tr>
	</tbody>
</table>
<p>
	&nbsp;</p>
<table border="1" cellpadding="1" cellspacing="1" style="width: 500px; ">
	<tbody>
		<tr>
			<td>
				&nbsp;</td>
			<td>
				&nbsp;</td>
		</tr>
	</tbody>
</table>
<p>
	&nbsp;</p>

comment:2 Changed 8 years ago by Garry Yao

Status: confirmedpending

Do you mean by copying the cell content? WFM on Chrome 14.

comment:3 Changed 8 years ago by Krzysztof Studnik

I am still able to reproduce it under Chrome 14(winxp), Chrome 13(ubuntu)

  1. insert default table
  2. in first cell, enter some text
  3. select text by mouse (set cursor at the end of text, click and drag mouse so cursor goes outside table - selection should look like on previously attached screen, whole cell is selected.)
  4. press ctrl+c
  5. press ctrl+v (with the selection still active)

Result as in comment 1

Other issue: Steps as above to step no.4, then as follows

  • set caret at the end of text in first cell
  • press ctrl+v

Result: a cell is pasted into first cell in second column
Expected: selection is pasted in the same cell as caret.

Last edited 8 years ago by Krzysztof Studnik (previous) (diff)

comment:4 Changed 7 years ago by Jakub Ś

Resolution: worksforme
Status: pendingclosed

I was not able to reproduce the original issue in latest CKEditor 3.6.2 but I was able to reproduce issue number 2 reported by @krst - I have reported it here #8471.

The original issue is no longer reproducible - closing this one.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy