Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7132 closed Bug (fixed)

Paste toolbar buttons are becoming disabled

Reported by: James Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.5.3
Component: UI : Toolbar Version: 3.5.1
Keywords: IBM IE Cc: Damian, Teresa Monahan, Satya Minnekanti, e@…

Description

Steps to reproduce the defect:

  1. Open the Ajax sample.
  2. Click on the paste button in the toolbar to display the paste dialog.
  3. Click on the cancel button.
  4. Repeat steps 2 & 3.

Result: The paste buttons in the toolbar become disabled.

N.B. This is always reproducible in IE7 & IE8 and has been reproduced in FF 3.6.8 but it is not reproducible in other versions of FF e.g. 3.6.6

Attachments (1)

7132.patch (416 bytes) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by Krzysztof Studnik

Keywords: IE added
Status: newconfirmed
Version: 3.5.2 (SVN - trunk)3.5.1

comment:2 Changed 7 years ago by Edwin Grubbs

Cc: e@… added

comment:3 Changed 7 years ago by Edwin Grubbs

This appears to be a problem that only occurs when you click "Allow access" when asked "Do you want to allow this webpage to access your clipboard?"

Then, the paste button becomes disabled if the clipboard contains an image or something else that can't be pasted into the text box. Unfortunately, ckeditor doesn't know exactly when the clipboard changes from containing an image to containing text. Therefore, to reactivate the paste button, you have to copy something from the ckeditor text box, and then you can copy something from another window.

Changed 7 years ago by Garry Yao

Attachment: 7132.patch added

comment:4 Changed 7 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

comment:5 Changed 7 years ago by Damian

Can we assign a milestone for this?

comment:6 Changed 7 years ago by Wiktor Walc

Milestone: CKEditor 3.5.3

comment:7 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:8 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

This's already fixed in [6478].

comment:9 Changed 7 years ago by Satya Minnekanti

I could still reproduce this issue on nightly build. Could you ple reopen this defect

comment:10 Changed 7 years ago by Jakub Ś

We have tried this scenario in many configurations and could not reproduce this ticket. Could you provide us with more details?

comment:11 Changed 7 years ago by James Cunningham

I can reproduce this on the 3.5.2 version of the editor but I cannot reproduce it on the current 3.5.3 version so it must be fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy