Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7138 closed Bug (fixed)

api.html sample in Opera does not work as expected

Reported by: Wiktor Walc Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.5.3
Component: General Version: 3.0
Keywords: Opera Cc:

Description (last modified by Alfonso Martínez de Lizarrondo)

Content from textarea is not read correctly in Opera due to a browser bug.

Steps to reproduce

  1. Open _samples/api.html
  2. Change the default HTML in the plain textarea below CKEditor:
    <h2>Test</h2><p>This is some <a href="/Test1.html">sample</a> HTML code.</p>
    

into something else, e.g.:

<p>Foo Bar</p>
  1. Press "insertHtml" button

Looks like the same issue as described here (issue with hidden textarea in Opera): http://stackoverflow.com/questions/3723963/jquery-val-does-not-work-for-textarea-in-opera

Attachments (2)

7138.patch (486 bytes) - added by Wiktor Walc 7 years ago.
7138_2.patch (906 bytes) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by Wiktor Walc

Description: modified (diff)
Status: newconfirmed

Changed 7 years ago by Wiktor Walc

Attachment: 7138.patch added

comment:2 Changed 7 years ago by Wiktor Walc

Owner: set to Wiktor Walc
Status: confirmedreview

comment:3 Changed 7 years ago by Garry Yao

Seems to be fixed with Opera 11?

comment:4 Changed 7 years ago by Wiktor Walc

I still have this problem in Opera 11.01 (build 1190).

Changed 7 years ago by Garry Yao

Attachment: 7138_2.patch added

comment:5 Changed 7 years ago by Garry Yao

Owner: changed from Wiktor Walc to Garry Yao

Let's try to avoid making hacks in sample page.

comment:6 Changed 7 years ago by Sa'ar Zac Elias

Keywords: Opera added
Status: reviewreview_passed

comment:7 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6460].

comment:8 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Description: modified (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy