Opened 9 years ago

Closed 6 years ago

#7137 closed Bug (fixed)

insertHtml( ' ') inserts a plain space

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Firefox IE Cc:

Description

Basically, this is a copy of #2248.

The editor.insertHtml( ' ') call inserts a plain space in the selection, instead of the proper   char.

Confirmed on Firefox, Safari.

Change History (5)

comment:1 Changed 9 years ago by Wiktor Walc

Status: newconfirmed

comment:2 Changed 8 years ago by Jakub Ś

Keywords: Firefox IE added

I have checked it under latest browsers.

Looks like the issue is only reproducible in IE an Firefox. In Webkit and Opera seems to be fine.

comment:3 Changed 8 years ago by Jakub Ś

In my opinion #8236 has the same cause as this one.

comment:4 Changed 7 years ago by Jakub Ś

In editor 4.x or CKE 3.x

Whether you use CKEDITOR.instances.editor1.insertHtml( ' '); or api sample to insert   you will get nothing when switching to source and back.

comment:5 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Fixed in CKEditor 4.0.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy