Opened 8 years ago

Closed 6 years ago

#7136 closed Bug (invalid)

Non-breaking space disappears from the end of block

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Cc:

Description

In browsers other than IE (I've checked Firefox, Safari, Opera), the non-breaking space at the end of block is changed into a space.

May have something to do with https://bugzilla.mozilla.org/show_bug.cgi?id=437044 (reported by Fred while working on #2248)

Steps to reproduce

  • In source mode paste:
    Foo 
    
  • Switch to wysiwyg mode
  • Type "Bar"
  • Result: Foo Bar
  • Expected result: Foo Bar

Same issue exists in FCKeditor.

Change History (2)

comment:1 Changed 8 years ago by Wiktor Walc

Status: newconfirmed

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: confirmedclosed

Transformation of   to normal space is an expected behaviour.

Imagine such case. You want to write 'foo bar'.

  1. You write 'foo'.
  2. You type space. This is a space at the end of block, so because of HTML nature this has to be   because otherwise it won't be visible. So you've got 'foo '.
  3. You type 'b'. So you expect to have 'foo b'. But imagine what would happen after you typed this 50 times. You would have one, non breakable line of text. Thus, browser has to transform that   to normal space after you typed next characters.
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy