Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#7157 closed Bug (fixed)

IE9 - in Document mode IE9 standards, CKEditor does not run

Reported by: Krzysztof Studnik Owned by:
Priority: Normal Milestone: CKEditor 3.5.2
Component: Project : CKPackager Version: 3.0
Keywords: IE9 Cc: tadoka2003@…

Description

IE9 v 9.0.8080.16413

  • fresh install of IE9, cache cleared
  • go to nightly builds and select any sample

Result:
CKEditor does not load into text areas. If it loads Open console (IE developer tools):

  • set browser mode to IE9
  • set Document mode to IE9 standards

Result, a JS error in console (in Nightly):

SCRIPT1004: Expected ';' 
ckeditor.js, line 14 character 238
SCRIPT5009: 'CKEDITOR' is undefined 
ui_languages.html, line 98 character 6

The {{{SCRIPT1004}} part, occurs in all CKEditor versions

Change History (7)

comment:1 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Status: newconfirmed

Reported at https://connect.microsoft.com/IE/feedback/details/643040/ckeditor-broken-in-rc

It seems to be a problem with the javascript compression, and it also affects CKFinder.

comment:2 Changed 8 years ago by Garry Yao

Component: GeneralProject : CKPackager
Milestone: CKEditor 3.5.2
Resolution: fixed
Status: confirmedclosed

Caused by mandatory semi-colon required for do...while in IE9, I'd say it a bug instead of an improvement, as old school way (optional semi-colon) introduce no ambiguousness at all.

Fixed with [6424:6425].

comment:3 Changed 8 years ago by Wiktor Walc

Milestone: CKEditor 3.5.3CKEditor 3.5.2

comment:4 Changed 8 years ago by savagekabbage

FYI - It looks like IE9 has fixed this in their latest GA version.

comment:5 Changed 7 years ago by Gene

Cc: tadoka2003@… added
Version: 3.03.6.4

I'm still experiencing this bug in CkEditor version 3.6.4

My site is forced to implement Document Mode: IE 9 Standards by adding:

<meta http-equiv="X-UA-Compatible" content="IE=9.0">

The current demo loaded in [www.ckeditor.com/demo] is in IE 7 Standards Mode. When you change that to IE 9 Standards by pressing F12 in IE, it will still work though.

But if you start the site in IE 9 Standards by implementing the above code, the editor will not show, only the toolbar.

comment:6 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Version: 3.6.43.0

The demo at www.ckeditor.com/demo runs in IE 9 standards mode by default, and it works fine here.

If you're "forced to implement Document Mode: IE 9 Standards", that might mean that your site has other problems because by default IE 9 tries to use the best standards mode.

comment:7 Changed 7 years ago by Jakub Ś

The current demo loaded in [www.ckeditor.com/demo] is in IE 7 Standards Mode. When you change that to IE 9 Standards by pressing F12 in IE, it will still work though.

That is not true. IE9 runs in IE9 mode by default and trust me there is no problem with default implementation. I would rather look for problems on your page or web app.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy