Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#7155 closed Bug (fixed)

pasteFromWordRemoveFontStyle broken in v3.5.1

Reported by: jorp Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.5.1
Keywords: Cc:

Description

  1. Set "pasteFromWordRemoveFontStyle" to false
  2. Open Word and enter some text and apply a color to it.
  3. Copy and paste the text into ckeditor
  4. The message "It was not possible to clean up the pasted data due to an internal error" appears.

From what I can gather, the mere existence of a "style" attribute seems to be what is causing the issue.

This bug does not appear in 3.5.

I have attached a zip with two tests,

/3.5/TEST/3.5-test.html /3.5/TEST/test.doc /3.5.1/TEST/3.5.1-test.html /3.5.1/TEST/test.doc

Change History (4)

comment:1 Changed 8 years ago by jorp

I tried to attach a couple of test cases, but upload keeps timing out. Sorry.

comment:2 in reply to:  1 Changed 8 years ago by jorp

Replying to jorp:

I tried to attach a couple of test cases, but upload keeps timing out. Sorry.

Sorry about the formatting in the bug report. Didn't realize a single line break would be collapsed.

comment:3 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: newclosed

Regression of [63171], fixed with [6438].

comment:4 Changed 5 years ago by Frederico Caldeira Knabben

Component: Core : PastingPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy