Opened 9 years ago

Closed 9 years ago

#7221 closed Bug (fixed)

A click on a horizontal list's element makes it become a vertical list

Reported by: guillaumesmo Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.5.4
Component: Core : Styles Version: 3.5.1
Keywords: IBM Cc: satya_minnekanti@…

Description

When you have a horizontal list (which is a list with list-style-type:none and li elements display:inline) and you click on a list element, the element goes to the next line as if he becomes a vertical list element. Going to source view and back to wysiwyg view makes the list horizontal again.

Paste the following code in the source view of a ckeditor, and then go back to wysiwyg view. Now click on a "lol" to reproduce the bug.

<style>
ul.list1{margin:20px 0px 0px 0px; padding:0px; list-style-type:none;}
ul.list1 li{display:inline; padding:20px;}
</style>
		<ul class="list1">
			<li>
				lol</li>
			<li>
				lol</li>
			<li>
				lol</li>
			<li>
				lol</li>
			<li>
				lol</li>
			<li>
				lol</li>
		</ul>

I'm using Mac OS X Snow Leopard with FireFox 3.5.16

Attachments (2)

7221.patch (516 bytes) - added by Garry Yao 9 years ago.
7221_2.patch (884 bytes) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by Krzysztof Studnik

Component: GeneralCore : Styles
Status: newconfirmed
Version: 3.5.1

comment:2 Changed 9 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added
Keywords: IBM added

Changed 9 years ago by Garry Yao

Attachment: 7221.patch added

comment:3 Changed 9 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

Be styling proof on path block evaluation.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

There is good part of the code that depends on the current behavior of the elements path class. Because of this, a few strange things started to happen, after patch:

  • The elements path bar "body > ul > p > li" when inside a list item.
  • By hitting ENTER at the end of the list, the elements path bar shows "body > ul > p". If you then type some text and go to source, the text moves before the list.

comment:5 Changed 9 years ago by Garry Yao

Status: review_failedreview

That's true, actually the ticket tc is a boundary pusher, as by our design dtd semantics are first-class citizens of behavior guide thus making the editor work with display-mangled structure (which is commonly happened when using the editor as an design tool instead of content composer) will not be our priority, so a simple fix that just make editor respect user content would be enough here.

Changed 9 years ago by Garry Yao

Attachment: 7221_2.patch added

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.5.4
Status: reviewreview_passed

comment:7 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6816].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy