Opened 8 years ago

Closed 3 years ago

#7220 closed Bug (duplicate)

[IE] Weird behavior when applying a block format on a table

Reported by: Sa'ar Zac Elias Owned by: Garry Yao
Priority: Normal Milestone:
Component: Core : Styles Version: 3.3
Keywords: IBM Cc: satya_minnekanti@…

Description

  • Add a table and click on its border.
  • Open the format combo, choose Heading 1.
  • Note that the selected option now look weird and nothing else happens.
  • Now click on the Heading 2 option.
  • Note that a few <h2> tags were added on top on the table, and the table had been corrupted.

Attachments (1)

krst_20110301-04.png (23.7 KB) - added by Krzysztof Studnik 8 years ago.
First 3 steps

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by Krzysztof Studnik

Attachment: krst_20110301-04.png added

First 3 steps

comment:1 Changed 8 years ago by Krzysztof Studnik

Status: newconfirmed
Version: 3.3

DUP/Related to #7017

comment:2 Changed 8 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added
Keywords: IBM added

comment:3 Changed 8 years ago by Garry Yao

Component: GeneralCore : Styles
Keywords: IE removed

Applies to FF and IE when select entire table as element selection.

comment:4 Changed 8 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

TCs and fixes landed on domiterator feature branch with [6924] and [6925].

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

There are two issues in this ticket. Let's leave this one handling the apply style problem, while #7582 handles the "weird selection" problem.

comment:6 Changed 8 years ago by Frederico Caldeira Knabben

The domiterator branch is supposed to land on v4 only. Until then we're not supposed to have a fix here.

comment:7 in reply to:  6 Changed 8 years ago by Frederico Caldeira Knabben

Status: reviewassigned

Replying to fredck:

The domiterator branch is supposed to land on v4 only. Until then we're not supposed to have a fix here.

I'm holding the review because of this.

comment:8 Changed 5 years ago by Piotrek Koszuliński

This issue is still reproducible, however not on Firefox any more and not on IE11. Additionally, the requirement is that a table is completely empty, which makes this a pretty edge case.

comment:9 Changed 3 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: assignedclosed

I'm still able to reproduce this on IE9. Not reproducible in Chrome (most likely due to inability to select the whole table from outside.

Besides, this is a dup of #7017.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy