Opened 7 years ago

Closed 4 years ago

#7253 closed Bug (fixed)

Maximize functionality in Firefox fails without doctype tag

Reported by: Justin King Owned by:
Priority: Normal Milestone:
Component: UI : Skins Version: 3.4.3
Keywords: Cc:

Description (last modified by Krzysztof Studnik)

Attempting to maximize a textarea in Firefox 3.6.13 causes a css rendering issue. In Chrome however this seems to function fine. Tested with the following code:

<html>
<head>
   
    <link href="ckeditor/_samples/sample.css" rel="stylesheet" type="text/css" />    

    <script type="text/javascript" src="http://code.jquery.com/jquery-1.5.1.min.js"></script>
    <script type="text/javascript" src="ckeditor/ckeditor.js"></script>
    <script type="text/javascript" src="ckeditor/adapters/jquery.js"></script>
    <script type="text/javascript">
        $(document).ready(function(){
            $('.editor').ckeditor();
        });
    </script>
</head>
<body>
    <h1>CKEditor Demo</h1>
    <textarea id="editor1" class="editor" name="editor1"><p>Initial value.</p></textarea>
</body>

</html>

adding this line resolved: <!DOCTYPE html PUBLIC "-W3CDTD XHTML 1.0 TransitionalEN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Video attached as well.

Attachments (1)

2011-02-28_1415.swf (496.0 KB) - added by Justin King 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Justin King

Attachment: 2011-02-28_1415.swf added

comment:1 Changed 7 years ago by Krzysztof Studnik

Component: GeneralUI : Skins
Description: modified (diff)
Status: newconfirmed
Version: 3.5.23.4.3

I confirm that without proper doctype tag, CKEditor is broken after maximizing

I used a "tuned" jquery sample. It looks like before 3.4.3 maximizing worked fine under FF3. Since 3.4.3, above issue happens.

comment:2 Changed 7 years ago by grimm26

Confirmed here as well. I had: <!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.0 TransitionalEN"> and maximize did not work. Switching to a doctype of: <!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01EN" "http://www.w3.org/TR/html4/strict.dtd">

fixed the issue.

comment:3 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

I could not reproduce this issue any more. I don't know if it's because quirks mode in FF has been changed or if it's something about editor. For example, I saw a quirks mode check in maximize plugin, so maybe this issue was fixed in other ticket. After removing that check maximize stops working, although result is a bit different.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy