Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#7269 closed Bug (fixed)

paste from word - footnote links link to document path in webkit based browsers

Reported by: Tomas Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.6.1
Component: Plugin : Paste from Word Version: 3.0
Keywords: WebKit HasPatch Cc:

Description

When pasting a document with footnotes, the links to the footnotes in webkit browsers get the full path to the doc, e.g. file:///c:/folder/doc.docx#ftn_1 instead of the more correct #ftn_1 as in IE and Gecko.

Patch that fixes this is provided.

Attachments (3)

Test with footnote.docx (13.0 KB) - added by Tomas 6 years ago.
test docx
fix_webkit_anchor_links_in_footnotes.patch (709 bytes) - added by Tomas 6 years ago.
patch for _source\plugins\pastefromword\filter\default.js
7269.patch (636 bytes) - added by Frederico Caldeira Knabben 6 years ago.

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by Tomas

Attachment: Test with footnote.docx added

test docx

Changed 6 years ago by Tomas

patch for _source\plugins\pastefromword\filter\default.js

comment:1 Changed 6 years ago by Tomas

The document needs to be saved, if you create a new document without saving it, then webkit will behave like ie and gecko.

comment:2 Changed 6 years ago by Krzysztof Studnik

Component: GeneralCore : Pasting
Keywords: Webkit Haspatch added
Status: newconfirmed
Version: 3.5.23.0

Behaviour under webkit browsers confirmed since CKE v3.0

Changed 6 years ago by Frederico Caldeira Knabben

Attachment: 7269.patch added

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

Keywords: WebKit HasPatch added; Webkit Haspatch removed
Owner: set to Frederico Caldeira Knabben
Status: confirmedreview

Other than small issues with code style, I had some troubles to apply the patch. I did it and it works pretty well. Thanks toma25!

comment:4 Changed 6 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1
Resolution: fixed
Status: review_passedclosed

Fixed with [6974].

comment:6 Changed 4 years ago by Frederico Caldeira Knabben

Component: Core : PastingPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy