Opened 12 years ago

Closed 12 years ago

#732 closed Bug (fixed)

combined font names lookup

Reported by: anonymous Owned by:
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: General Version:
Keywords: SF Cc:

Description

It seams that in the combined font names situation, only over IE, the browser returns the actually applied font, instead of the combined string. In Firefox it works well.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1494362&group_id=75348&atid=543653

Change History (2)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to anonymous

Hi FredCK,

I would like to ask you for help once again...

I need to modify the FontName dropdown to contain a list of fonts defined in sql table.

That's fine as I use FCKEditor.NET integration and assign the FontNames dynamically in code behind.

The case is that each row in the dropdown is not supposed to be one single font name but rather a comma separated list of fonts.

So an example row looks like : 'Courier New,Arial,Tahoma'

That's fine as well.

So when I highlight some text and choose mentioned above item from font list I got 'font' tag applied with 'face' attribute set to those three font names separated by commas.

But when I move the cursor outside of the previously selected text and then back on it, in the 'FontName' combobox the 'Courier New,Arial,Tahoma' wont get highlighted as is gets when using regular font ( not comma separated list of fonts ).

I suppose that I need to modify the method which selects the proper item in FontName combobox when cursor is moved, but I just couldn't find it...

Thanks,

Hi Maciej,

This is not as easy as it seams.

The problem is that the browser internal functions are used to retrieve the current font name. It seams that in the combined font names situation, only over IE, the browser returns the actually applied font, instead of the combine string. In Firefox it works well.

I would ask you to please fill a bug report for it, so we can I can manage to work on this in future versions: https://sourceforge.net/tracker/?group_id=75348&atid=543653

Best regards, Frederico Caldeira Knabben



Moved from SF. Original poster: Anonymous

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.5
Resolution: fixed
Status: newclosed

Fixed with [774]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy