Opened 7 years ago

Closed 6 years ago

#7321 closed Bug (fixed)

IE6: Right borders missing in dialog textfields in RTL languages

Reported by: James Cunningham Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.1
Component: UI : Dialogs Version: 3.0
Keywords: IBM IE6 Cc: Damian, Satya Minnekanti, Teresa Monahan

Description

Steps to reproduce the defect:

  1. Open the languages sample in IE6.
  1. Select a RTL language i.e. Arabic/Hebrew.
  1. Open the Table dialog.
  1. Click on the Advanced tab.

Result: See that the right border of the Style textfield is missing.

  1. Click into any of the other textfields & type some text.

Result: See that the right border is missing after entering text into a textfield (see screenshot).

  1. Click on the Table Properties tab.

Result: See that most of the right borders are missing.

Attachments (8)

border missing issue.jpg (17.7 KB) - added by James Cunningham 7 years ago.
7321.patch (1.4 KB) - added by Sa'ar Zac Elias 6 years ago.
borders missing.jpg (26.5 KB) - added by Satya Minnekanti 6 years ago.
7321_2.patch (1.8 KB) - added by Garry Yao 6 years ago.
ckeditor_borders_rtl.png (15.3 KB) - added by Wiktor Walc 6 years ago.
ckeditor_borders.png (8.9 KB) - added by Wiktor Walc 6 years ago.
7321_3.patch (1.7 KB) - added by Garry Yao 6 years ago.
ckeditor_ie8_quirks_patch3.png (11.4 KB) - added by Wiktor Walc 6 years ago.

Download all attachments as: .zip

Change History (24)

Changed 7 years ago by James Cunningham

Attachment: border missing issue.jpg added

comment:1 Changed 7 years ago by James Cunningham

This issue is also present in IE7 Quirks mode and IE8 Quirks mode.

comment:2 Changed 7 years ago by Krzysztof Studnik

Status: newconfirmed
Version: 3.5.3 (SVN - trunk)3.0

Occurs in all dialogs since v3.0 in RTL languages

comment:3 Changed 6 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedassigned

Changed 6 years ago by Sa'ar Zac Elias

Attachment: 7321.patch added

comment:4 Changed 6 years ago by Sa'ar Zac Elias

Status: assignedreview

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

I see no changes after patch.

Btw, this issue (very similar, actually) can be verified with IE9+Quirks also.

comment:6 Changed 6 years ago by Frederico Caldeira Knabben

Status: review_failedreview_passed

Ops... I did something wrong. Nice job!

comment:7 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1

comment:8 Changed 6 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6937].

comment:9 Changed 6 years ago by Satya Minnekanti

I could still see the borders missing on nightly build. Please re open the ticket. i have attached a screenshot.

Changed 6 years ago by Satya Minnekanti

Attachment: borders missing.jpg added

comment:10 in reply to:  9 Changed 6 years ago by Krzysztof Studnik

Replying to satya:

I could still see the borders missing on nightly build. Please re open the ticket. i have attached a screenshot.

I agree. Checked with CKEditor r7013

comment:11 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: closedreopened

Changed 6 years ago by Garry Yao

Attachment: 7321_2.patch added

comment:12 Changed 6 years ago by Garry Yao

Owner: changed from Sa'ar Zac Elias to Garry Yao
Status: reopenedreview

comment:13 Changed 6 years ago by Wiktor Walc

Though not 100% related with the original TC, I still see some problems in IE6:

  • in the Image dialog in LTR language (right borders are missing)

  • in RTL mode, Image dialog, in the "Advanced" tab (left border is missing)

Last edited 6 years ago by Wiktor Walc (previous) (diff)

Changed 6 years ago by Wiktor Walc

Attachment: ckeditor_borders_rtl.png added

Changed 6 years ago by Wiktor Walc

Attachment: ckeditor_borders.png added

Changed 6 years ago by Garry Yao

Attachment: 7321_3.patch added

Changed 6 years ago by Wiktor Walc

comment:14 Changed 6 years ago by Wiktor Walc

The third patch caused that IE8 in Quirks mode not does not render input fields correctly in LTR mode (they used to take all the available space, now it looks less nice).

If I had to choose whether to:

  1. render borders for all fields in IE6 (with 7321_3.patch) for the price of shortening significantly input fields in LTR mode
  2. or live with the issue that I described for LTR language (right border is mising in IE6) while keeping current length of input elements,

I'd choose the second option. In other words, the third patch is not right imho, the Image dialog should not look like in the image below:

If there's no way to fix the things that I mentioned, let's just focus on the original TC and stay with the second patch.

comment:15 Changed 6 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

Ok.. r+ for the 7321_2.patch.. it's ugly though :/

Last edited 6 years ago by Sa'ar Zac Elias (previous) (diff)

comment:16 Changed 6 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [7031].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy