Opened 7 years ago

Closed 7 years ago

#7335 closed Bug (worksforme)

Find cannot search for a string longer than 80 chars

Reported by: IBM_RQM Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.1
Keywords: IBM Cc:

Description

I typed in some lines of text that were about 300 characters or so long. I selected a bunch of the text and copied it. I then used the Find feature in the editor to see if it would find the string. I was surprised that the Find feature could not find the string. Currently it looks like the Find functionality can only search of a string up to 80 characters long. Beyond that length the Find functionality reports that it cannot find the string, regardless of the string being there or not. If the string being searched on is 100 characters long for example and is actually present in the editor, the Find functionality reports that it cannot find it.

The error message needs to be updated to let the user know that the Find works for strings up to 80 characters in length. In a large document, the user will mistakenly think that a line of text is not in the document when in actuality the problem is that the string being searched on is too long for the Find to search for it.

Change History (3)

comment:1 Changed 7 years ago by IBM_RQM

Keywords: IBM added

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Status: newpending

Works for me with both IE and Firefox.

Using this HTML:

<p>This is some <strong>sample text</strong>.</p>
<p>80: 12345678901234567890123456789012345678901234567890123456789012345678901234567890</p>
<p>81: 123456789012345678901234567890123456789012345678901234567890123456789012345678901</p>
<p>100: 1234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890</p>
<p>You are using <a href="http://ckeditor.com/">CKEditor</a>.</p>

I was able to use the find dialog successfully, with its default options, for all three long strings.

Do you have a more precise test case for it?

comment:3 Changed 7 years ago by IBM_RQM

Resolution: worksforme
Status: pendingclosed

I could not reproduce the issue reported by the user either.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy