Opened 8 years ago

Closed 5 years ago

#7355 closed Bug (invalid)

[IE9] Pixelsharp toolbar layout

Reported by: Dinu Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version: 3.0
Keywords: IE9 Cc:

Description

In IE9, toolbar widths seem to have a strange fractional width, which change the horizontal width with by as much as 5-6 px (in my use case). I couldn't trace if this is due to CSS (I'm not at all familiar with the UI design) or a rendering bug.

Attachments (2)

ScreenShot.jpg (92.9 KB) - added by Dinu 8 years ago.
Button width: is 53 in all other browsers
pack.zip (332.2 KB) - added by Dinu 8 years ago.
Another difference

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by Dinu

Attachment: ScreenShot.jpg added

Button width: is 53 in all other browsers

comment:1 Changed 8 years ago by Jakub Ś

Keywords: IE9 added
Status: newconfirmed
Version: 3.5.3 (SVN - trunk)3.0

"Source" button has width set to auto because it displays localized text. IE9 renders this button smaller than in all other browsers. It is 3px smaller (tested on polish locale) to be more precise.

comment:2 Changed 8 years ago by Dinu

For me, it seems all are larger...

comment:3 Changed 8 years ago by Jakub Ś

I have checked those buttons using many locales and I haven't found any differences except in source button. Even other buttons displaying localized messages had the same width in all browsers. I definitely can't confirm such situation for buttons containing icons.

After tests I'm almost 100% sure that this situation is valid only for source button. The fact is that there is a difference and it should be checked.

comment:4 Changed 8 years ago by Dinu

I attach another difference. Sorry again for using web3, couldn't find time to replicate on CK demo.

Changed 8 years ago by Dinu

Attachment: pack.zip added

Another difference

comment:5 Changed 8 years ago by Dinu

Config for above:

toolbar:[
	['Source'],
	['Cut','Copy','Paste','PasteText','PasteFromWord'],
	['Undo','Redo','-','Find','Replace','-','SelectAll','RemoveFormat'],
	['Image','Flash','Table','HorizontalRule','Smiley','SpecialChar'],
	'/',
	['Bold','Italic','Underline','Strike','-','Subscript','Superscript'],
	['NumberedList','BulletedList','-','Outdent','Indent','Blockquote','CreateDiv'],
	['JustifyLeft','JustifyCenter','JustifyRight','JustifyBlock'],
	['Link','Unlink','Anchor'],
	'/',
	['Styles','Format','Font','FontSize'],
	['TextColor','BGColor'],
	['ShowBlocks']
]

comment:6 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: confirmedclosed

I don't see a bug here. IE9 indeed claims that the "Source" button has float width, but it's not CKEditor setting it. IE does it, because the width is automatic. This is weird, but it doesn't cause any problems.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy