Opened 7 years ago

Closed 7 years ago

#7361 closed Bug (invalid)

BIDI: Indentation is not applied to a RTL list item in a mixed content list

Reported by: James Cunningham Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3
Keywords: IBM Cc: Damian, Satya Minnekanti, Teresa Monahan

Description

Steps to reproduce the defect:

  1. Open the Ajax sample.
  1. Paste in the following code:
<ul>
	<li dir="rtl">
		1</li>
	<li>
		[2</li>
	<li>
		3]</li>
</ul>
  1. Select the first list item & click on increase indent.

Expected: The first list item (RTL) becomes indented.

Actual: List items 2 & 3 (LTR) become indented.

Change History (2)

comment:1 Changed 7 years ago by Krzysztof Studnik

Status: newconfirmed
Version: 3.5.3 (SVN - trunk)3.3

comment:2 Changed 7 years ago by Garry Yao

Resolution: invalid
Status: confirmedclosed

Indent the first list item actually indent the whole list, which is in LTR, so it's not a bug.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy