Opened 8 years ago

Closed 8 years ago

#7386 closed Bug (duplicate)

Switching modes (wysiwyg/source) not setting focus properly

Reported by: Dane Bertram Owned by:
Priority: Normal Milestone:
Component: UI : Source View Version: 3.5.2
Keywords: Cc: dane@…

Description

Steps:

  1. Go to www.ckeditor.com/demo
  2. Set focus inside the editor body
  3. Click on the "Source" button to enter HTML source mode

Result: Source mode is displayed, but the textarea does not have focus
Expected: Focus set to the textarea

Furthermore, once you're in source mode if you then:

  1. Click on the "Source" button again to return to WYSIWYG mode

Result: WYSIWYG mode is displayed, but the editor does not have focus
Expected: Focus set to the editor

This feels like a bug to me, but after searching for similar cases and reading over previous related bugs that have been closed, I'm not so sure.

My expected/desired behavior is also related to ticket #3709 (cursor position and/or the current selection should be remain intact when switching between editor modes).

Change History (1)

comment:1 Changed 8 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

Not setting focus to textarea is the expected behavior of CKEditor. We don't see much sense in setting the focus because it can be either set at the beginning or at the end of the textarea. Such solution is almost identical to not having focus at all.

The second request duplicates ticket #3709, that is why it will be marked as duplicate.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy