Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7388 closed Bug (invalid)

Code changes after page is edited

Reported by: Han Kooiman Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.5
Keywords: Cc:

Description

http://www.pierewaaienscheveningen.nl/

This is about the fck editor build in the Website Baker CMS. Everytime I have to make a change in the Homepage of this site, I have to renew the code of the Addthis script:

<!-- AddThis Button BEGIN -->
<div class="addthis_toolbox addthis_default_style ">
<a href="http://www.addthis.com/bookmark.php?v=250&amp;username=pierewaaienscheveningen" class="addthis_button_compact">Share</a>
<span class="addthis_separator">|</span>
<a class="addthis_button_facebook"></a>
<a class="addthis_button_hyves"></a>
<a class="addthis_button_twitter"></a>
<a class="addthis_button_email"></a>
</div>
<script type="text/javascript">var addthis_config = {"data_track_clickback":true};</script>
<script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js#username=pierewaaienscheveningen"></script>
<!-- AddThis Button END -->

Everytime the WYSIWYG feature is used, the code will be changed to:

<!-- AddThis Button BEGIN -->
                        <div class="addthis_toolbox addthis_default_style "><a class="addthis_button_compact" href="http://www.addthis.com/bookmark.php?v=250&amp;username=pierewaaienscheveningen">Share</a> <span class="addthis_separator">|</span></div>
                        <script type="text/javascript">var addthis_config = {"data_track_clickback":true};</script><script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js#username=pierewaaienscheveningen"></script><!-- AddThis Button END -->

And that does not work as intended! Hope you can help!

Change History (2)

comment:1 Changed 9 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

FCKEditor and CKEditor remove empty elements by default. Try to add empty spaces to your anchors like this:

<a class="addthis_button_facebook"> </a>
<a class="addthis_button_hyves"> </a>
<a class="addthis_button_twitter"> </a>
<a class="addthis_button_email"> </a>

That way they won't by removed and you might achieve what you want. Those spaces will be removed when script pasting images is fired, so they should not cause any problems. Hope this helps.

In the future, when you are not having problem with CKEditor directly, try using our forums - http://cksource.com/forums/ - you might find many interesting solutions there.

You can also subscribe to our dedicated support - http://ckeditor.com/support

comment:2 Changed 9 years ago by Han Kooiman

Sorry, I tried to add empty spaces to the anchors, but the anchors are still being removed from the code whenever I change to WYSIWYG mode:

<!-- AddThis Button BEGIN -->
<div class="addthis_toolbox addthis_default_style ">
<a href="http://www.addthis.com/bookmark.php?v=250&amp;username=pierewaaienscheveningen" class="addthis_button_compact">Share</a>
<span class="addthis_separator">|</span>
<a class="addthis_button_facebook"> </a>
<a class="addthis_button_hyves"> </a>
<a class="addthis_button_twitter"> </a>
<a class="addthis_button_email"> </a>
</div>
<script type="text/javascript">var addthis_config = {"data_track_clickback":true};</script>
<script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js#username=pierewaaienscheveningen"></script>
<!-- AddThis Button END -->
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy