Opened 8 years ago

Closed 5 years ago

#7392 closed Bug (wontfix)

With multiple editor instances running, page is scrolled to last one in FireFox 3.6

Reported by: Gernot Kieseritzky Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3.2
Keywords: FF3 Cc:

Description

If multiple editor instances are active on one page, the last/lowest instance automatically receives focus upon load. This happens only in Firefox (tested with V3.6.15 but not IEs) and only if all text areas are empty. This happens despite of CKEDITOR.startupFocus being set to 'false' explicitely. This is likely related to bug #4472 which was supposedly fixed in V3.4.1. I've attached a test page.

Attachments (1)

focus_test_case.zip (1.1 MB) - added by Gernot Kieseritzky 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by Gernot Kieseritzky

Attachment: focus_test_case.zip added

comment:1 Changed 8 years ago by Jakub Ś

Keywords: FF3 added
Status: newconfirmed
Summary: With multiple editor instances running last one gets focus in FireFox 3.6.15With multiple editor instances running, page is scrolled to last one in FireFox 3.6
Version: 3.5.13.3.2

If multiple editor instances are used on one page, than the page is scrolled to the last instance of CKEditor. This happens only in Firefox 3.6 and only if all text areas are empty. It's also worth to add that FF4 behaves correctly (doesn’t scroll).

As user pointed out, this bug is very similar to #4472.

The problem has started to occur since CKEditor version 3.3.2

comment:2 Changed 8 years ago by exstac

The bug seems to be related to these lines of code:

var keyEventSimulate = doc.$.createEvent( "KeyEvents" );
keyEventSimulate.initKeyEvent( 'keypress', true, true, win.$, false, false, false, false, 0, 32 )
doc.$.dispatchEvent( keyEventSimulate );

If I remove them the bug no longer occurs.

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

That code is there to fix #5781. The scroll issue is in fact #4472, but for some unknown reason the fix proposed there is not working for FF3.6.

The best approach here would be first of all checking whether the fix for #5781 is needed for FF3.6. If not, we may consider avoiding it for that browser version. If that's still needed, then we need to check why [5873] is not being effective here.

comment:4 Changed 8 years ago by exstac

#5781 does apply to ff3.6. If those lines are removed the bug resurfaces. I did look into #4472 and the sample provided does not work with ff3.6.

It seems as if this is a timing issue though. If I insert a breakpoint and debug the code it works as intended.

comment:5 Changed 5 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: confirmedclosed

FF3.6.x is not supported any more.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy