Opened 9 years ago

Closed 9 years ago

#7396 closed Bug (duplicate)

Special Characters Window causes CKEditor to never open again.

Reported by: onepoint Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5
Keywords: Cc:

Description

Clicking the Omega (Special Characters) symbol, (http://screencast.com/t/LzmUDUbfl), selecting a character, and then clicking Ok, only to reopening CKEditor causes it never load properly (http://screencast.com/t/z4RGIXE5Bzm)

Chrome spits on an error:

Uncaught TypeError: Object #<Object> has no method 'indexOf' : ckeditor.js:9

Change History (5)

comment:1 Changed 9 years ago by Jakub Ś

Keywords: special characters special omega crash instance removed
Status: newpending

Were you able to reproduce the bug in CKEditor demo pages - http://ckeditor.com/apps/ckeditor/3.5.2/_samples/index.html (the last stable version) or in nightly build version - http://nightly.ckeditor.com/demo ? If you are able to reproduce it, could you please provide us with a step by step scenario?

I see that you are using CKEditor in your web application. Perhaps it's not the problem of CKEditor itself but your application settings?

comment:2 Changed 9 years ago by onepoint

Yes.

http://ckeditor.com/apps/ckeditor/3.5.2/_samples/ajax.html

What we're doing is removing the instance of CKEditor, and then creating a new one. It is essentially the exact same as

http://ckeditor.com/apps/ckeditor/3.5.2/_samples/ajax.html

What i did was, Create Editor, click the Omega Symbol, add anything (Example: Exclamation Point), Remove Editor, and then click Create Editor again, but only this time the same error spits out:

Uncaught TypeError: Object #<Object> has no method 'indexOf'

comment:3 Changed 9 years ago by Jakub Ś

Status: pendingconfirmed
Version: 3.5.23.5

Sorry I've missed something that obvious.

The error occurs in file ckeditor/_source/core/tools.js in line 522 Log from FireBug : array.indexOf is not a function - return array.indexOf( entry );

The error has started occurring since CKEditor version 3.5.

comment:4 Changed 9 years ago by onepoint

Is there a current work around in place?

comment:5 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Resolution: duplicate
Status: confirmedclosed

dup of #7088 (fixed in the nightlies)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy