Opened 5 years ago

Closed 5 years ago

Last modified 5 months ago

#7433 closed Bug (fixed)

[IE9] enterBr doesn't put cursor to next line

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.5.3
Component: UI : Enter Key Version: 3.0
Keywords: IE9 Cc:

Description

With IE9 standard mode:

  1. Load any of the sample page;
  2. Put cursor at the end of block and press one shift enter;
  3. Press shift enter again;
    • Expected Result: Cursor moved to the next line;
    • Actual Result: Cursor stays at the same line.

Attachments (1)

7433.patch (1.5 KB) - added by garry.yao 5 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 5 years ago by garry.yao

  • Milestone set to CKEditor 3.5.3
  • Status changed from new to confirmed

Changed 5 years ago by garry.yao

comment:2 Changed 5 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

This's a new IE9 regression that report wrong range position for any range anchors besides BR node.

The workaround is a about a new (and shorter) way to determinate IE selection range, it create an empty anchor element as marker and report its position instead of relying on traditional position comparison approach.

comment:3 Changed 5 years ago by Saare

  • Status changed from review to review_passed

Let's file a IE bug.

comment:4 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

IE bug filed.

Fixed with [6624].

comment:5 Changed 3 years ago by berend_engelbrecht

This problem came back in IE10. Steps to reproduce:

  • Download latest stable ckeditor
  • Add this line in config.js: config.enterMode = CKEDITOR.ENTER_BR;
  • Try any of the samples in IE10 standard mode.

Note that every second enter key press does not result in a new line in the editor.

The IE-specific code in changeset 6624 that fixes Ticket #7433 is only reached if .ie9Compat evaluates to true. Replace .ie9Compat by .ie && .version >= 9 and the problem is resolved in ie10 as well.

Please note that the change for ticket #9535 (with similar description) does not fix this problem.

comment:6 Changed 3 years ago by j.swiderski

@berend_engelbrecht I have reported #10943.

comment:7 Changed 3 years ago by Reinmar

I tried to reproduce this on IE9 and IE10 on 4.2.1 and latest master with no luck.

comment:8 Changed 21 months ago by jamadam

Hi. I'm strugling with this issue on IE10 + version 3.6.6.2.

With IE10 standard mode:

  • Load sample page (say replacebyclass.html);
  • Put cursor at the end of block and press one shift enter;
  • Press shift enter again;
    • Expected Result: Cursor moved to the next line;
    • Actual Result: Cursor stays at the same line.

I tried to backport the patches below from #9535 but doesn't work.

https://github.com/ckeditor/ckeditor-dev/commit/d8c53c14b86dd244f892bdef025f9eb43a414535#diff-ae237139107d046c67dc8622d25bace9R1615

https://github.com/ckeditor/ckeditor-dev/commit/7d66fdda897612a2c7521616820e3282c394304f

comment:9 Changed 21 months ago by j.swiderski

I wasn't able to reproduce this in CKEditor 4.x and we won't be fixing this issue for CKEditor 3.x thus we suggest upgrading.

comment:10 Changed 5 months ago by jade_jen8

I have this issue with the 4.5.6 standard version of ckeditor in ie9, both in compatibility and non-compatibility mode. It occurs intermittently, but happens more often when I press the enter key to a different text box before going to the ckeditor text area.

To reproduce:

Get 4.5.6 standard version of ckeditor

In config.js add line: config.enterMode = CKEDITOR.ENTER_BR

In a different input text box (in my case I have an asp.net textbox), type a sample text and press enter.

Either tab or click on the ckeditor and type text and press enter - cursor stays at the same line instead of going to the next line--it only goes to next line when I type additional texts.

Last edited 5 months ago by jade_jen8 (previous) (diff)

comment:11 Changed 5 months ago by jade_jen8

  • Version changed from 3.0 to 4.5.6

comment:12 Changed 5 months ago by j.swiderski

  • Version changed from 4.5.6 to 3.0

First of all don't change version number - it is used to indicate when problem has stared.

Second, the bug is closed. You should have filed new one and linked the old one.

Third, it should be enough to download CKEditor full pre-set, open replace by code sample, add textarea there and set enter mode. After some typing I should see the problem but I haven’t gotten such result.
In my case in IE9 everything was working as expected with default editor.

Please check this issue with default CKEditor outside of your application (CKEditor should act as standalone "application" (it's enough to put ckeditor folder on server) on your server). If you are able to reproduce this isssue with default editor, please file a new ticket linking back to this one and explaining exact steps to reproduce this issue.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy