Opened 10 years ago

Closed 10 years ago

#7436 closed Bug (invalid)

BIDI - after alligning text to right, rtl setting is not respected any more

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: Core : BiDi Version: 3.4.2
Keywords: Cc:

Description

1) Paste the following text: "This is some sample text. You are using"

2) Align text to right.

3) Click button 'rtl'

4) Place the cursor after word "using" and start typing or press space and start typing or press enter and start typing.

5) The elements are created with attribute 'rtl' but when I write the text inside them it's 'ltr'.

Is this normal behavoiur of CKEditor?

Till CKEditor version 3.4.1 when you align sample text to right and press 'rtl' 'ltr' buttons nothing happens.

Change History (7)

comment:1 Changed 10 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 10 years ago by Sa'ar Zac Elias

Status: confirmedpending

As for steps 2,3 - are they in the correct order? BIDI mirroring takes place when you change the language direction, so at this point the text goes back to the left.

comment:3 Changed 10 years ago by Sa'ar Zac Elias

Also, is that a solely a FF issue?

comment:4 Changed 10 years ago by Jakub Ś

Keywords: FF IE Opera added; FF3 removed
Status: pendingconfirmed

Steps 2 and 3 are in correct order. I agree when you place 'rtl' button the text goes back to the left. That is correct.

BUT when you start typing, with 'rtl' button set, the text is written from left to right. Steps 4 and 5. I'm not sure if that's correct behaviour.

It occurs in FF, IE, Opera. I couldn't reproduce it in Webkit.

comment:5 Changed 10 years ago by Jakub Ś

Keywords: FF IE Opera removed

comment:6 Changed 10 years ago by Jakub Ś

Important note: it was tested on Polish keyboard (ltr).

Perhaps correct result can be achieved on Hebrew keyboard (rtl)?

comment:7 Changed 10 years ago by Sa'ar Zac Elias

Resolution: invalid
Status: confirmedclosed

That is the expected result due to the nature of LTR writing in RTL container.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy