Opened 7 years ago

Closed 7 years ago

#7437 closed Bug (fixed)

[WebKit] Caret disappears after applying inline style on collapses selection

Reported by: Sa'ar Zac Elias Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.5.3
Component: General Version: 3.5.3
Keywords: Chrome Cc:

Description

On Webkit, applying an inline style on a collapsed selection (sounds weird huh? ;)) makes the cusror to disappear.

Attachments (1)

7437.patch (1.9 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by Wiktor Walc

Keywords: Chrome added; WebKit removed
Status: newconfirmed

Confirmed, but only in Chrome. WFM in Safari 5 @ Mac and Safari 5 @ Win 7.

comment:2 Changed 7 years ago by Garry Yao

Status: confirmedpending

WFM on both Chrome and Safari @Win7? Can you confirm it's a Mac-only issue?

comment:3 Changed 7 years ago by Sa'ar Zac Elias

Problem is reproducible on Chrome 10.0.648.204 @ Win7.

comment:4 Changed 7 years ago by Garry Yao

Owner: set to Garry Yao
Status: pendingreview

Confirmed this bug is caused by a regression since Chrome 10, affects also 11 beta.

Changed 7 years ago by Garry Yao

Attachment: 7437.patch added

comment:5 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:6 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6636].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy