Opened 12 years ago

Closed 12 years ago

#744 closed Bug (fixed)

Anchors do not work in Firefox. FCKEditor version 2.2.1

Reported by: mirella77@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc: mauritsvanrees@…, Frederico Caldeira Knabben, stephantual_@…

Description

After saving the document where an anchor is created the link to the anchor is changed. It put hardcoded the root url before the #anchorname.

Example: <a href="#text below">link to text below</a>

Becomes after saving (url of my localtestmachine): <a href="http://localhost:8030/#text below">link to text below</a>

This only happens in Firefox. Internet Explorer does not touch your href code when you save your created anchor.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1507157&group_id=75348&atid=543653

Change History (2)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to mirella77@…

Looked again with Mirella.

It goes wrong when you are in Source Code view and then save the document.


Moved from SF. Original poster: mauritsvanrees

Still doesn't work correctly. Using FCKeditor from the svn collective at plone.org now; plone 2.1 svn branch, Zope 2.9.4, cmf 1.6. Using Firefox 1.5 (Ubuntu).

I add a document and edit the main text with FCKeditor so the source looks like this:


<a href="#anchor">link</a><br /> <br /> <a name="anchor"></a>anchor


I save and it looks just fine. But then I edit the document again and that's where it goes wrong. At least sometimes. I changed it to this:

<a href="#anchor">link</a><br />
<br />
<a name="anchor"></a>anchor<br />
<br />
<a href="#another">another link</a><br />
<br />
<a name="another"></a>another anchor<br />
<br />
and back to previous <a href="#anchor">anchor</a>.

which after/during saving is turned into:

<a href="http://localhost:8080/#anchor">link</a><br />
<br />
<a name="anchor"></a>anchor<br />
<br />
<a href="http://localhost:8080/#another">another link</a><br />
<br />
<a name="another"></a>another anchor<br />
<br />
and back to previous <a
href="http://localhost:8080/#anchor">anchor</a>.

But sometimes this happens and sometimes not. I can't really offer some steps that will always reproduce this. :( The general idea seems to be: add a document with link and anchor, then edit it again and perhaps change a line or click Source or something and save and then it may or may not go wrong. That's not the kind of bug report anyone looks forward to...

Hm, this *seems* to reproduce it:

  1. Add a new document, with an anchor and a link to it and

save it.

  1. Edit it again, go to the Source code and change something

there, e.g. add a <br />.

  1. Save it and (I hope) observe that the link now points to

something like "../..#anchor".

Actually, even simpler:

  1. Add a new document, with an anchor and a link to it.
  2. Go to the Source code and change something there, e.g.

add a <br />.

  1. Save it and (I hope) observe that the link now points to

something like "../..#anchor".

This is weird. BTW, I wouldn't be surprised if the bug that causes is turns out not to be in FCKeditor but in some deep part of Zope or Plone.


Moved from SF. Original poster: mauritsvanrees

Hi,

This bug has been solved with the latest version of FCKeditor.

Best regards, FredCK http://www.fckeditor.net "Support Open Source Software... What about a donation today?"

PS.: This is a canned response.


Moved from SF. Original poster: fredck

AFAIK this is fixed in 2.3 assumming you're using FF15. That bug can be closed IMHO.


Moved from SF. Original poster: stephantual_

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy