Opened 9 years ago

Closed 8 years ago

#7488 closed Bug (duplicate)

IE9 ignores multiple break points without   inserted after

Reported by: Michael Camden Owned by:
Priority: Normal Milestone:
Component: Core : Keystrokes Version: 3.5.2
Keywords: IE9 HasPatch Cc: mcamden@…

Description

Steps to reproduce:

  1. Set CKEDITOR.config.enterMode to CKEDITOR.ENTER_BR
  2. Open up CKEDITOR on IE9
  3. Type a sentence, press enter twice, type another sentence.

Expected result: Sentence 1

Sentence 2

Actual Result: Sentence 1 Sentence 2

The break tags are correctly being created by the editor, but it seems that IE9 is ignoring them.

How to fix: Open up enterkey\plugin.js

Ln# 273-274:

   if ( !CKEDITOR.env.ie )
      doc.createText( '\ufeff' ).insertAfter( lineBreak );

+ Add +

   else {
      doc.createElement( ' ' ).insertAfter( lineBreak );
   }

Change History (3)

comment:1 Changed 9 years ago by Michael Camden

I also forgot that I added this style,

br {
   display: block\9 !important;
}

comment:2 Changed 9 years ago by Wiktor Walc

Keywords: HasPatch added; line breaks has patch removed
Status: newpending

Could you check the nightly build?

Looks like a duplicate of ticket #7433, which has been fixed recently.

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: duplicate
Status: pendingclosed

Definitely a DUP of #7433.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy