Opened 12 years ago

Closed 7 years ago

#749 closed Bug (wontfix)

Extra paragraph break after Tables within fixed-height cells

Reported by: severy@… Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (FCKeditor) - Retired
Keywords: IE Cc:

Description

If a table of a fixed height is located inside a table cell of the exact same fixed height, an extra paragraph break is displayed after the table when the content is loaded into the editor in Internet Explorer. This problem does not occur in Firefox. With web pages that use a lot of tables within tables for layout, the content can look totally different within the editor as compared to in a regular browser window. The following sample HTML demonstrates the problem:

<html>
<head>
<Title>FCKeditor Table Layout Issue</title>
</head>
<body bgcolor="#0000FF">
<table width="100%" height="50" border="0"
cellpadding="0" cellspacing="0" bgcolor="#FF0000">
<tr height="50">
<td width="100%" height="50">
<table width="100%" height="50" border="0"
cellpadding="0" cellspacing="0">
<tr><td bgcolor="#00FF00"
width="100%"></td></tr>
</table>
</td>
</tr>
</table>
</body>
</html>

Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1511448&group_id=75348&atid=543653

Change History (4)

comment:1 Changed 12 years ago by Martin Kou

Cc: Frederico Caldeira Knabben added
Reporter: changed from Martin Kou to severy@…

This is something really difficult to fix. Actually most probably not possible to.

The problem is that the browser, which give the basic editing features to the editor, renders that space after the table so the user can place the cursor there and start typing text. It is not a case that the space is exactly height as the cursor caret.

So, in one side it could become a problem, but it you really want to place something there, it is a feature. Actually, the Firefox behavior would be considered a bug in other cases, because it almost impossible to place some text right after the green table, inside the same red cell.

More research will be done for it, but I don't see much possibilities here. Only a fix from Microsoft, but I don't see much possibilities on having something from that side.

Best regards, Frederico Caldeira Knabben


http://www.fckeditor.net "Support Open Source Software... What about a donation today?"


Moved from SF. Original poster: fredck

comment:2 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed IE added
Version: SVN

Confirmed in IE. Works with FF2

comment:3 Changed 10 years ago by Artur Formella

The same bug occurs in CKEditor 3.0 beta 3667.

comment:4 Changed 7 years ago by Jakub Ś

Cc: Frederico Caldeira Knabben removed
Keywords: SF removed
Resolution: wontfix
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy