Opened 8 years ago

Closed 8 years ago

#7497 closed New Feature (fixed)

Broken HTML - the order of elements is changed in the editor

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: satya_minnekanti@…

Description

Not sure if we can actually do anything with it.

The following code (without the opening tag to start the unordered list):

<p>
	Text above list</p>

	<li>
		One</li>
	<li>
		Two</li>
	<li>
		Three</li>
</ul>
<p>
	Text below list</p>
<p>
	Another paragraph below</p>

is changed into:

<p>
	Text above list</p>
<p>
	Text below list</p>
<p>
	Another paragraph below</p>
<ul>
	<li>
		One</li>
	<li>
		Two</li>
	<li>
		Three</li>
</ul>

Change History (6)

comment:1 Changed 8 years ago by Wiktor Walc

Results in CKEditor 3.5.2

IE8

<p>
	Text above list</p>
<li>
	One</li>
<li>
	Two</li>
<li>
	Three</li>
<ul>
</ul>
<p>
	Text below list</p>
<p>
	Another paragraph below</p>

Firefox 3.6.16

<p>
	Text above list</p>
<li>
	One</li>
<li>
	Two</li>
<li>
	Three</li>
<p>
	Text below list</p>
<p>
	Another paragraph below</p>

comment:2 Changed 8 years ago by Wiktor Walc

Caused by [6561]

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Status: newconfirmed

I've added TC to cover this issue with [6642].

comment:4 Changed 8 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:5 Changed 8 years ago by Garry Yao

There's an original DT has wrong expectation as discovered by this ticket, in case that when fixing a structure, position of the elements after it should remains, updated with [6645].

comment:6 Changed 8 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: confirmedclosed

Fixed by #7494 with [6646].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy