Opened 9 years ago

Closed 5 years ago

#7519 closed Bug (fixed)

style buttons do not toggle correctly in IE at the beginning of a non-empty paragraph

Reported by: Frank Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IBM IE Cc: martti.jeenicke@…, Michael.Bruegmann@…, satya_minnekanti@…

Description

In Internet Explorer 8 positioning the cursor on the beginning of a non empty paragraph and clicking on a basic style button (bold or italic) does not toggle the style button in the toolbar. The style is applied and when typing you will see the style in the text area. The problem only arises in non-empty paragraphs.

Change History (5)

comment:1 Changed 9 years ago by Satya Minnekanti

Cc: martti.jeenicke@… Michael.Bruegmann@… satya_minnekanti@… added; martti.jeenicke@… removed
Keywords: IBM added

This happens in I6, IE7 as well

comment:2 Changed 9 years ago by Jakub Ś

Keywords: IE added
Status: newconfirmed
Version: 3.5.23.0

This has been true for all versions of IE since CKEditor version 3.0

Opera has also problem with text-formatting buttons. Please see #7496 .

comment:3 Changed 8 years ago by Frank

We would really like to know if this bug will eventually be fixed. The Bug report has been idle for nine month now.

comment:4 Changed 8 years ago by mohlendo

Any chance of a fix? Or any other reaction?

comment:5 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

This issue is not reproducible any more.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy