Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#7521 closed Bug (fixed)

IE: Editing a table pasted table adds a new empty table in editor body.

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.4.1
Keywords: IBM Cc: Damian, James Cunningham, Teresa Monahan

Description

To reproduce the defect:

  1. Copy and paste a table from the attached word doc using paste from word dialog.
  1. keep cursor in one of table cells and open Table Properties dialog by clicking on Table Properties section in context menu.
  1. Press OK button on the dialog with out changing any properties.

Expected Result:

Table Properties dialog is closed, and table remains the same.

Actual Result:

Table Properties dialog is closed, but a new empty table with 3 rows and 2 cols is added.

  1. Open Table Properties dialog again from context menu, and try to click OK Button to close the dialog.

Expected Result:

Table Properties dialog is closed, and table remains the same.

Actual Result:

Table Properties dialog not closed and we it will show an error on status bar and Error is Invalid argument

Attachments (1)

simple table.doc (24.5 KB) - added by Satya Minnekanti 8 years ago.

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by Satya Minnekanti

Attachment: simple table.doc added

comment:1 Changed 8 years ago by Jakub Ś

Status: newpending

I have tested this issue in version 3.5.2 and in revision version [6565] (http://rev.ckeditor.com/ckeditor/trunk/6565/_samples/) in all browsers and didn't get the expected result.

In which browser did you get this problem, and in which sample? Perhaps OS also matters?

Could you please provide me with more details.

comment:2 in reply to:  1 Changed 8 years ago by Satya Minnekanti

Replying to j.swiderski:

I have tested this issue in version 3.5.2 and in revision version [6565] (http://rev.ckeditor.com/ckeditor/trunk/6565/_samples/) in all browsers and didn't get the expected result.

In which browser did you get this problem, and in which sample? Perhaps OS also matters?

Could you please provide me with more details.

I have tested it against nightly build & i could reproduce this problem in IE6,IE7 & IE8 and my OS is Windows XP.

Best way to reproduce is keep the cursor in first cell of the pasted Table and open Table Properties dialog and press OK button with out changing any properties as i mentioned in the steps to reproduce.

This issue happens only for tables pasted from word.

comment:3 Changed 8 years ago by Wiktor Walc

Status: pendingconfirmed

Confirmed in IE6 using the following source: (use "click here" table cell to reproduce it)

<p>
	&nbsp;</p>
<table border="1" cellpadding="0" cellspacing="0">
	<tbody>
		<tr>
			<td style="width: 197px">
				<p>
					Ewrew</p>
			</td>
			<td style="width: 197px">
				<p>
					435</p>
			</td>
			<td style="width: 197px">
				<p>
					43543543</p>
			</td>
		</tr>
		<tr>
			<td style="width: 197px">
				<p>
					Werw</p>
			</td>
			<td style="width: 197px">
				<p>
					435</p>
			</td>
			<td style="width: 197px">
				<p>
					click here</p>
			</td>
		</tr>
		<tr>
			<td style="width: 197px">
				<p>
					435</p>
			</td>
			<td style="width: 197px">
				<p>
					435435</p>
			</td>
			<td style="width: 197px">
				<p>
					ertretretre</p>
			</td>
		</tr>
	</tbody>
</table>

"Invalid argument", Line 174, core/dom/node.js:

insertBefore : function( node )
{
	node.$.parentNode.insertBefore( this.$, node.$ ); // <----
	return node;
},

comment:4 Changed 8 years ago by Wiktor Walc

@satya - did you manage to confirm this bug in IE8 in IE8 standards mode? I can only reproduce it in IE6.

comment:5 in reply to:  4 Changed 8 years ago by Satya Minnekanti

Replying to wwalc:

@satya - did you manage to confirm this bug in IE8 in IE8 standards mode? I can only reproduce it in IE6.

I could reproduce it on IE6 & IE7 but not IE8

comment:7 Changed 8 years ago by Krzysztof Studnik

Version: 3.5.3 (SVN - trunk)3.4.1

I was able to reproduce it since CKE v3.4.1, for IE6

comment:8 Changed 8 years ago by Jakub Ś

I have managed to reproduce it on both IE6 and IE7.

When you click "cell -> cell properties" and than press OK on dialog without making changes - error illegal argument occurs. For "cell properties" this has been true since CKEditor version 3.4.1;

Problem described here for "table properties" is the same but I was able to reproduce it only in CKEditor 3.5.3 svn. This might be because of thicket #7529

comment:9 Changed 8 years ago by Garry Yao

Cc: damo,jamescun,tmonahandamo, jamescun, tmonahan
Resolution: fixed
Status: confirmedclosed

Fixed by [6882] on trunk.

comment:10 Changed 5 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy