Opened 12 years ago

Closed 11 years ago

#753 closed Bug (fixed)

Arrowing over an image skips the next char (Firefox only)

Reported by: anonymous Owned by:
Priority: Normal Milestone: FCKeditor 2.6
Component: General Version:
Keywords: Confirmed Firefox SF CantFix Cc:

Description (last modified by Martin Kou)

The bug occurs when using the arrow keys to navigate text in firefox.

If there is an image within a line of text, arrowing right across it will cause the cursor to skip the character immediately after the image.

Example: (the | represents the cursor and each iteration represents the right-arrow keypress)

1: some te|xt[IMAGE}some more
2: some tex|t[IMAGE]some more
3: some text|[IMAGE]some more
4: some text[IMAGE]s|ome more

Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1513587&group_id=75348&atid=543653

Change History (5)

comment:1 Changed 12 years ago by Martin Kou

Description: modified (diff)
Reporter: changed from Martin Kou to anonymous

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: CantFix added
Milestone: FCKeditor 2.6

This is a FF bug. We can't do much to solve it, but we must be sure we have it reported at Bugzilla. Targeting to 2.6 to do that.

comment:3 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed FF added

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Firefox added; FF removed

comment:5 Changed 11 years ago by Martin Kou

Resolution: fixed
Status: newclosed

Upon testing, the issue is found to have been fixed in Firefox 3.0 beta 2.

Closing ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy