Opened 12 years ago

Closed 12 years ago

#754 closed Bug (fixed)

Editor always gets focus when loaded in frame in IE

Reported by: jongunnip@… Owned by:
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: General Version:
Keywords: SF Cc:

Description

In a frames environment in IE 6, if a link in a frame opens a window in that frame with an instance of FCKEditor, the cursor will be in the editor. The user can start typing, but the editor does not have focus, so tabbing causes the user to go the address bar and then step through each frame.

This is a usability issue when the editor as part of a form within frames. Users need to click on the editor to give it focus. Also, sometimes the editor is in the middle of a form, so we wouldn't want it to have focus when the frame loads.

In Firefox, the editor does not get focus when the frame loads, which is what I would expect should occur.

I reproduced this issue by updating _samples/html/sample01.html to have a link to reload itself, and then putting sample01.html in a frame. I will attach the files.

This is probably very low priority. Thanks for looking at it! Jon


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1515259&group_id=75348&atid=543653

Attachments (2)

frame.html (234 bytes) - added by Martin Kou 12 years ago.
sample01.html (2.1 KB) - added by Martin Kou 12 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to jongunnip@…

Changed 12 years ago by Martin Kou

Attachment: frame.html added

Changed 12 years ago by Martin Kou

Attachment: sample01.html added

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.5
Resolution: fixed
Status: newclosed

I'm not able to reproduce it anymore. We have made changes to focus issues for version 2.5, which probably fixed this one too.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy