Opened 8 years ago

Closed 8 years ago

#7589 closed Bug (wontfix)

BIDI: IE8: Difficulties using backspace to delete RTL paragraphs.

Reported by: James Cunningham Owned by:
Priority: Normal Milestone:
Component: Core : BiDi Version: 3.0
Keywords: IE8 IBM CantFix Cc: Damian, Satya Minnekanti, Teresa Monahan

Description

Steps to reproduce the defect:

  1. Open the Ajax sample in IE8.
  1. Paste the following code into the source view:
<p dir="rtl">
	paragraph 1</p>
<p dir="rtl">
	paragraph 2</p>

  1. Change back to WYSIWYG mode.
  1. Place the cursor to the left of the letter p in the second paragraph & click backspace a few times.

Expected: The content in paragraph 1 should start being deleted.

Actual: Nothing happens.

Change History (3)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed
Version: 3.5.4 (SVN - trunk)3.0

Has happened since CKEditor version 3.0

To place the cursor click on paragraph two and press arrow key.
I'm writing about it because it took me a while to get to it:)

comment:2 Changed 8 years ago by Garry Yao

Due to a limitation of IE below version 9, RTL blocks are rendered as separate editing hosts so keystrokes are constraint to per editing host only, which makes it impossible to delete previous block (a different host). We could hardly do anything here of a fix.

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: CantFix added
Resolution: wontfix
Status: confirmedclosed

This issue doesn't touch IE versions before 9... it's limited to IE8. IE7 works well.

There is nothing we can do here, really. This is a bad bug of IE8.

Fortunately IE9 solves this problem and the upgrade rate of IE8 users to IE9 is expected to be high, when compared to previous IEs.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy