Opened 6 years ago

Closed 6 years ago

#7686 closed Bug (invalid)

Paste buttons in toolbar become disabled depending on the content in the clipboard

Reported by: James Cunningham Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.5.4
Keywords: IBM Cc: Damian, Satya Minnekanti, Teresa Monahan

Description

Steps to reproduce the defect:

  1. Right click on a file on your desktop & choose copy from the context menu so that the whole file is in the clipboard (not just the contents of the file). Note: I know that you cannot paste files into the editor. I have just added this content to the clipboard to demonstrate the test case.
  1. Open any sample of the editor in any browser.
  1. Click into the editor to give it focus.

Result: The Paste buttons in the toolbar are disabled (see screenshot).

I think ticket 7132 that was closed could have been caused by a similar issue.

Attachments (1)

disabled paste buttons.JPG (30.6 KB) - added by James Cunningham 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by James Cunningham

Attachment: disabled paste buttons.JPG added

comment:1 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: invalid
Status: newclosed

This is not a feature controlled by us, but I asume that the browser is not willing to enable these buttons if there is nothing "useful" to get pasted.

That's the expected behavior, considering that the paste buttons would do nothing.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy